0
$\begingroup$

Rosanswers logo

I use Ubuntu Oneiric and ROS Fuerte. When I install the package videre_stereo_cam, I got some link error. I tried adding the linker path with -L/usr/lib/libboost_signals.so and -lboost_signals in CMakeLists.txt but no luck.

I did find there are several camera packages which support IEEE 1394 camera. But they just give me mono image from my color camera. For example, coriander just provides mono format for my color camera. I doubt it is because they don't support videre camera well. That's why I am trying this videre_stereo_cam package.

The error messages are shown below when I run "rosmake videre_stereo_cam". Before that, rosdep shown "#All required rosdeps installed successfully".


Linking CXX executable ../bin/disparity_view

/usr/bin/ld: CMakeFiles/disparity_view.dir/src/disparity_view.o: undefined reference to symbol 'boost::signals::connection::~connection()'

/usr/bin/ld: note: 'boost::signals::connection::~connection()' is defined in DSO /usr/lib/libboost_signals.so.1.46.1 so try adding it to the linker command line

/usr/lib/libboost_signals.so.1.46.1: could not read symbols: Invalid operation

collect2: ld returned 1 exit status

make[3]: *** [../bin/disparity_view] Error 1

make[3]: Leaving directory `/home/gandalf/ros/videre_stereo_cam/build'

make[2]: *** [CMakeFiles/disparity_view.dir/all] Error 2

make[2]: Leaving directory `/home/gandalf/ros/videre_stereo_cam/build'

make[1]: *** [all] Error 2

make[1]: Leaving directory `/home/gandalf/ros/videre_stereo_cam/build'

[ rosmake ] Output from build of package videre_stereo_cam written to:

[ rosmake ] /home/gandalf/.ros/rosmake/rosmake_output-20120809-145037/videre_stereo_cam/build_output.log [rosmake-0] Finished <<< videre_stereo_cam [FAIL] [ 5.76 seconds]
[ rosmake ] Halting due to failure in package videre_stereo_cam. [ rosmake ] Waiting for other threads to complete. [ rosmake ] Results:
[ rosmake ] Built 36 packages with 1 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/gandalf/.ros/rosmake/rosmake_output-20120809-145037


Any ideas? Thank you!


Originally posted by LeonInTexas on ROS Answers with karma: 5 on 2012-08-09

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I just fixed compilation problems with fuerte, please update from svn trunk and try again.


Originally posted by arebgun with karma: 2121 on 2012-08-09

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.