1
$\begingroup$

I always wanted to have a CNC to make PCB quickly at home.

Finally, I got a 7x7 kit from zentools recently and put it together. I attached a battery powered screw driver to 2nd shaft of the stepper and moved the each axis all the way back and forward before wiring. All 3 axis moves smoothly, I can turn the steppers even by hand. Every piece works smoothly, no mechanical jam.

I decided to use GRBL as controller software. Tested the software without the shield or stepper (qv: Testing GRBL in Arduino Board without the steppers) I use Universal Gcode Sender to communicate with GRBL.

I got an Arduino CNC Shield for Arduino UNO, put it together, attached to Arduino UNO, re-tested GRBL, it worked.

I used Reprep's Stepper wiring article to connect stepper to the driver, wired 1 stepper to the stepper driver (X axis). Powered the shield with 20V 17.5Amp (350W) DC Regulated Power supply. (It was the power adaptor for an old 17" notebook. Notebook died, I kept the adaptor)

When the move 5 steps command (G1 X5) was sent, stepper makes a small move in the direction and then makes a grinding noise. (Can be seen on Youtube)

I tried switching 1st pair's cables, using another stepper driver (3 drivers), turning the potentiometer to increase the current, but still no luck.

I attached 2 photos of the cnc and the controller and controller unit.

I tried everything I can think of, any suggestions?

CNC Controller (the DC adapter at the bottom)

$\endgroup$
1
$\begingroup$

After reviewing the Polulu Stepper Driver manual, I realized I was wiring stepper wires in wrong order.

The controller pin labels are: 1A, 1B, 2A, 2B. The controller card's manual was saying 'use letters as pair' but it suppose to say 'use numbers as pair'.

Everything works perfectly after correcting the wires.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.