0
$\begingroup$

Rosanswers logo

Hello,

I am trying to spawn a table and a coffee cup into the empty world of pr2 following this tutorial http://www.ros.org/wiki/pr2_simulator/Tutorials/BasicPR2Controls:

1) I Copied the table.stl to this directory `rospack find   gazebo_worlds`/Media/models/
2) I Copied the table.urdf to this directory `rospack find gazebo_worlds`/objects/
3) roslaunch pr2_gazebo pr2_empty_world.launch----> works fine.
4) rosrun gazebo spawn_model -urdf -file table.urdf -model table -x 1.0 -y 0.5 -z 0.3
5) rosrun gazebo spawn_model -gazebo -file `rospack find gazebo_worlds`/objects/coffee_cup.model -model coffee_cup -x 1.2 -z 1

The result is so weird, the table was spawned with no color(same color as the background) while I have gotten the error message: "filename referred by mesh [table.stl] does not appear to exist."

The coffee cup was shown in the list of models but there is no coffee cup in the world. And there some error messages for this command : "namespace error : Namespace prefix model on physical is not defined"

Why do I get these error messages? And if I delete one object from the world, the entire gazebo window will be closed. Why?

p.s. I am working with Fuerte ROS on Ubuntu 12.0.4

Thanks,


Originally posted by Zara on ROS Answers with karma: 99 on 2012-08-07

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The last part of what you are mentioning has happened to many who are using fuerte. The bug has been fixed. Regarding the uncoloured object, the fuerte does not support the all the materials that the electric does and neither the simulator_gazebo tutorial nor the pr2_simulator tutorial is updated. There is no material called LightWood in fuerte. Try basic colours like Blue Red etc. I would also suggest you to switch back to electric (on ubuntu 11.04 if possible). I myself went to fuerte and tried working on gazebo but found too many bugs. So, I came back to electric. Hope this helps!


Originally posted by prasanna.kumar with karma: 1363 on 2012-08-07

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by Zara on 2012-08-08:
Thanks for your answer. How about the coffee cup? Why do I get Namespace error? and there is no coffee cup in the world.

Comment by aknirala on 2012-09-13:
I am facing similar problems, Not able to embed .model file in .world file.

I am also planning to switch back (after a little more try), were you able to install rosjava on electric?

Comment by aknirala on 2012-09-13:
Any specific reason why 10.04 and not 10.10?

Comment by prasanna.kumar on 2012-09-14:
I have no idea about rosjava and I worked neither on 10.04 nor 10.10 before with electric.

Comment by aknirala on 2012-09-14:
Thanks for your reply,

Ooops I mistakingly wrote 10.04 and 10.10. I meant to ask 11.10 and 11.04. Things were fine on 11.10 and electric (for me) except for ROSJAVA, (I was able to run it only once).

So any specific reason to prefer 11.04 over 11.10?

Comment by prasanna.kumar on 2012-09-14:
Nothing, I have never used 11.04 before (I don't even know how it looks like). Used 11.10 for a long time, upgraded to 12.04 and fuerte, found both crappy and downgraded both. You can work assured with this combination 11.04+electric!

Comment by aknirala on 2012-09-15:
ok, thanku

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.