0
$\begingroup$

Rosanswers logo

I have been trying to set up a turtle bot for the past couple days. So I went through the instructions found here and made it up to 5.4; when i typed in "rostopic list" into the workstation, it is unable to communicate with master.

ON WORKSTATION

echo $ROS_MASTER_URI

http://192.168.1.101:11311

echo $ROS_HOSTNAME

192.168.1.100

ON LAPTOP

echo $ROS_MASTER_URI

http://192.168.1.100:11311

echo $ROS_HOSTNAME

192.168.1.101

**Laptop IP=**192.168.1.101 **Workstation IP=**192.168.1.100

Any help with resolving this issue would be appreciated. Thanks!


Originally posted by buma676 on ROS Answers with karma: 91 on 2012-08-07

Post score: 1


Original comments

Comment by buma676 on 2012-08-07:
thanks, i changed the ROS_MASTER_URI as you said, but it is still unable to contact master. Any other ideas?

Comment by Lorenz on 2012-08-07:
Is the robot running? Did you start roscore? And don't set ROS_HOSTNAME to an ip address. Instead, use the variable ROS_IP.

Comment by buma676 on 2012-08-07:
when i start roscore i get WARNING: ROS_MASTER_URI [http://192.168.1.101:11311] host is not set to this machine

Comment by Lorenz on 2012-08-07:
Did you set ROS_IP and unset ROS_HOSTNAME?

Comment by buma676 on 2012-08-07:
i set up the ROS_IP; how do I unset the ROS_HOSTNAME?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

There will only be a single ROS master between the 2 machines, which by the given instructions should be on the turtlebot laptop. You should change your ~/.bashrc file on the laptop from:

export ROS_MASTER_URI=http://192.168.1.100:11311

to:

export ROS_MASTER_URI=http://192.168.1.101:11311

This assumes that your laptop has the IP 192.168.1.101 and your workstation has the IP 192.168.1.100


Originally posted by piyushk with karma: 2871 on 2012-08-07

This answer was ACCEPTED on the original site

Post score: 7

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.