0
$\begingroup$

Rosanswers logo

Hey,

OS: Fedora 14 ROS: Fuerte

Error, while initializing roscore:

Unable to contact my own server at [http://scitos:50689/]. This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself. Please check for errors by running:

ping scitos

For more tips, please see

http://www.ros.org/wiki/ROS/NetworkSetup

ping scitos delivers

unkown host scitos

ping localhost works fine, ping 127.0.0.1 likewise

Solutions according to ros-wiki is to set

ROS_HOSTNAME=localhost ROS_MASTER_URI=http://localhost:11311

this has not worked ping $ROS_HOSTNAME does fine, while ping $ROS_MASTER_URI returns

unknown host http://localhost:11311

Any ideas why this does not work? Maybe some issue concerning my network connection(using wireless for internet, still there are two ethernet accesses, which are currently not used)?

thx :-)


Originally posted by Flowers on ROS Answers with karma: 342 on 2012-07-30

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It's clear that you can't ping the ROS_MASTER_URI. Pinging the host in the ROS_MASTER_URI is the correct way.

Could you run a roscore after setting ROS_HOSTNAME?

The other way is checking your /etc/hosts. There should probably be a line like:

127.0.0.1   localhost

If you add

127.0.0.1   scitos

after that, you should be able to do ping scitos.


Originally posted by dornhege with karma: 31395 on 2012-07-30

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.