0
$\begingroup$

Rosanswers logo

Hello, trying to install stage on a working ROS (fuerte) install (verified through all tutorials), but at some point when I try to rosmake:

/usr/bin/ld: CMakeFiles/bin/stageros.dir/src/stageros.o: undefined reference to symbol '_ZN2Fl4waitEd' /usr/bin/ld: note: '_ZN2Fl4waitEd' is defined in DSO /lib/libfltk.so.1.3 so try adding it to the linker command line
/lib/libfltk.so.1.3: could not read symbols: Invalid operation collect2: error: ld returned 1 exit status
make[4]: *** [../bin/stageros] Error 1

No problems with rosdep either.

I thought this was related to this ticket, but shouldn't this be fixed? https://code.ros.org/trac/ros-pkg/ticket/4441

Thanks so much for any help!


Originally posted by user12821821 on ROS Answers with karma: 45 on 2012-07-27

Post score: 2


Original comments

Comment by Asomerville on 2012-07-27:
I don't know the answer, but what version of ROS you're working with will be important to answering the question.

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

On Fedora, that reference is supposed to be satisfied by installing fltk-devel.

What does this do?

$ rosdep install stage

UPDATE: try this, then check to see if the fltk package named is actually installed:

$ rosdep resolve fltk

UPDATE2: that #4441 fix was to an older version of stage (3.2.2). Fuerte has stage 4.1.1.

I can't tell whether or not that fix was ever applied upstream. It may have gotten lost in the version upgrade.

I recommend opening a new ticket for Fuerte, referring back to #4441 and to this question.


Originally posted by joq with karma: 25443 on 2012-07-27

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by user12821821 on 2012-07-27:
When I do "rosdep install stage" I get the message: "#All required rosdeps installed successfully" then when I retry rosmake I get the exact same error.

Comment by user12821821 on 2012-07-27:
When I do "rosdep resolve fltk" I get the message: "#yum" followed by the message "fltk-devel" , when I retry rosmake I get the exact same error.

Comment by joq on 2012-07-28:
Does yum say fltk-devel is actually installed?

Comment by user12821821 on 2012-07-29:
When I do yum list installed I have entries for : "fltk.i686", "fltk-devel.i686", "fltk-fluid.i686" and all of these three have a version of 1.3.0-4.fc17 thanks so much for your help btw it is greatly appreciated.

Comment by user12821821 on 2012-07-30:
Okay thanks so much for your help, submitted a ticket #5507

$\endgroup$
0
$\begingroup$

Rosanswers logo

For anyone still having issues, this patch fixes things for fedora: https://code.ros.org/trac/ros-pkg/attachment/ticket/5507/fltk-find-package.patch


Originally posted by cottsay with karma: 311 on 2013-01-28

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by user12821821 on 2013-03-07:
Thanks for the update!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.