Rosanswers logo

I'm running ROS fuerte in Ubuntu 12.04LTS. Complete fresh installation. No issues setting it up.

The problem appears whenever I try to render a model in rviz I get only a partially rendered model. For example if I launch the Motoman planning components with the line;

roslaunch sia10d_mesh_arm_navigation planning_components_visualizer.launch

I get a render of a a bunch of disjointed triangles which almost represent the robot.

I figure this may be an issue with my graphics card, which is a NVidia Geforce GT630M with Optimus (Which I know linux doesn't support the Optimus technology). I believe Ubuntu ignores the Nvidia card in this setup (by default) and just uses the Intel integrated graphics.

Everything else seems to run fine. Other 3D graphics packages display .stl files fine, it just seems to be an issue with rviz and this setup.

I was wondering if anyone else has come across this issue, and whether there is an easy fix, or should I do battle with trying to upgrade my graphic driver?

Update: Can render .dae (Collada) files. Possibly similar to this: https://code.ros.org/trac/ros-pkg/ticket/5111

Originally posted by Jeremy Corbett on ROS Answers with karma: 397 on 2012-07-26

Post score: 0


1 Answer 1


Rosanswers logo

The problem is that Ubuntu 12.04 still does not support laptops with Optimus technology so they default to the Intel integrated graphics.

The Intel integrated graphics card on the Ivy-bridge i7's aren't well supported in linux yet either so they lack the ability to render certain 3D graphics.

There are a couple of solutions;

  • Get an older laptop that has a supported graphics card.
  • Attempt to trick the linux kernel into using the NVidia Card instead of the integrated graphics.
  • Just stick to using .dae files and dodge the graphics issues the best you can.

Originally posted by Jeremy Corbett with karma: 397 on 2012-10-15

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by Eric Perko on 2012-10-15:
Can you disable the Optimus and force full-time use of the nvidia card via a BIOS setting? I know there are Dells and Thinkpads that have such an option.

Comment by JonW on 2012-10-15:
I have been using bumblebee (https://wiki.ubuntu.com/Bumblebee) on an optimus laptop with some success. Rviz and gazebo have been working quite well.

Comment by Martin Günther on 2012-10-15:
Correct answer. The problems you describe typically appear with most Intel GMA chip sets.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.