0
$\begingroup$

Rosanswers logo

Hello,

I have recently upgraded to Ubunto 12.0.4 and trying to reinstall ROS (Fuerte version). I have got the following error message. Even installing each package separately doesn't help. It seems that I am stuck inside a loop of dependencies.

p.s. Still I have the old version of ROS on my computer; No idea how to get rid of it.

sudo apt-get install ros-fuerte-desktop-full Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-fuerte-desktop-full : Depends: ros-fuerte-nodelet-core (= 1.6.5-s1342844070~precise) but it is not going to be installed Depends: ros-fuerte-geometry-tutorials (= 0.1.3-s1342872775~precise) but it is not going to be installed Depends: ros-fuerte-orocos-kinematics-dynamics (= 0.2.3-s1342843099~precise) but it is not going to be installed Depends: ros-fuerte-filters (= 1.6.0-s1342847409~precise) but it is not going to be installed Depends: ros-fuerte-slam-gmapping (= 1.2.7-s1342854377~precise) but it is not going to be installed Depends: ros-fuerte-simulator-gazebo (= 1.6.10-s1342860235~precise) but it is not going to be installed Depends: ros-fuerte-visualization (= 1.8.13-s1342850128~precise) but it is not going to be installed Depends: ros-fuerte-vision-opencv (= 1.8.3-s1342843578~precise) but it is not going to be installed Depends: ros-fuerte-perception-pcl (= 1.2.2-s1342844331~precise) but it is not going to be installed Depends: ros-fuerte-geometry-experimental (= 0.2.3-s1342855049~precise) but it is not going to be installed Depends: ros-fuerte-robot-model-visualization (= 0.1.2-s1342859854~precise) but it is not going to be installed Depends: ros-fuerte-common-tutorials (= 0.2.3-s1342876317~precise) but it is not going to be installed Depends: ros-fuerte-image-pipeline (= 1.8.3-s1342844697~precise) but it is not going to be installed Depends: ros-fuerte-bfl (= 0.1.0-s1342847793~precise) but it is not going to be installed Depends: ros-fuerte-diagnostics-monitors (= 1.4.3-s1342858172~precise) but it is not going to be installed Depends: ros-fuerte-common-rosdeps (= 1.2.0-s1342842909~precise) but it is not going to be installed Depends: ros-fuerte-geometry-visualization (= 0.1.1-s1342935189~precise) but it is not going to be installed Depends: ros-fuerte-image-common (= 1.8.0-s1342843441~precise) but it is not going to be installed Depends: ros-fuerte-bond-core (= 1.6.3-s1342843973~precise) but it is not going to be installed Depends: ros-fuerte-python-qt-binding (= 0.1.5-s1342848822~precise) but 0.1.5-s1342850931~oneiric is to be installed Depends: ros-fuerte-visualization-common (= 1.8.4-s1342848914~precise) but it is not going to be installed Depends: ros-fuerte-physics-ode (= 1.8.0-s1342848419~precise) but it is not going to be installed Depends: ros-fuerte-driver-common (= 1.4.0-s1342842829~precise) but it is not going to be installed Depends: ros-fuerte-executive-smach (= 1.2.0-s1342854953~precise) but it is not going to be installed Depends: ros-fuerte-stage (= 1.6.6-s1342867130~precise) but it is not going to be installed Depends: ros-fuerte-dynamic-reconfigure (= 1.4.0-s1342842723~precise) but it is not going to be installed Depends: ros-fuerte-image-transport-plugins (= 1.8.0-s1342843694~precise) but it is not going to be installed Depends: ros-fuerte-xacro (= 1.6.1-s1342845815~precise) but it is not going to be installed Depends: ros-fuerte-robot-model (= 1.8.0-s1342845259~precise) but it is not going to be installed Depends: ros-fuerte-bullet (= 2.79-s1342842972~precise) but it is not going to be installed Depends: ros-fuerte-pluginlib (= 1.8.0-s1342842444~precise) but it is not going to be installed Depends: ros-fuerte-geometry (= 1.8.1-s1342843265~precise) but it is not going to be installed Depends: ros-fuerte-visualization-tutorials (= 0.6.3-s1342937133~precise) but it is not going to be installed Depends: ros-fuerte-executive-smach-visualization (= 1.0.2-s1342873735~precise) but it is not going to be installed Depends: ros-fuerte-laser-pipeline (= 1.4.4-s1342847526~precise) but it is not going to be installed Depends: ros-fuerte-common (= 1.8.0-s1342847255~precise) but it is not going to be installed Depends: ros-fuerte-diagnostics (= 1.6.4-s1342842594~precise) but it is not going to be installed Depends: ros-fuerte-navigation (= 1.8.2-s1342847954~precise) but it is not going to be installed E: Unable to correct problems, you have held broken packages.


Originally posted by Zara on ROS Answers with karma: 99 on 2012-07-26

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You can remove electric with

sudo apt-get remove ros-electric-*

After that you can try to re-install fuerte. I assume that some package's system library dependency conflicts with your previously installed electric versions, which won't be available for 12.04.


Originally posted by AHornung with karma: 5904 on 2012-07-26

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.