0
$\begingroup$

Rosanswers logo

hi, i have a litte problem, my costmap2d node does not subscribe my /scan topic which publishes sensor_msgs/LaserScan

Rosparam get /costmap_node/scan/: {clearing: true, data_type: LaserScan, expected_update_rate: 0.5, marking: true, max_obstacle_height: 0.4, min_obstacle_height: 0.08, observation_persistence: 0.0, topic: /scan}

In rxgraph i see that it does not subscribe my /scan topic, but my gmapping is unsing /scan and all works fine.

here is my costmap_common.yaml : costmap/transform_tolerance: 1.0 costmap/footprint: [[-0.3, -0.3], [-0.3, 0.3], [0.3, 0.3], [0.3, -0.3]] observation_sources: scan scan: {data_type: LaserScan, expected_update_rate: 0.5, topic: /scan, observation_persistence: 0.0, marking: true, clearing: true, max_obstacle_height: 0.4, min_obstacle_height: 0.08}

any ideas ?


Originally posted by pkohout on ROS Answers with karma: 336 on 2012-07-19

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Try this configuration:

observation_sources: laser_scan_sensor

laser_scan_sensor: {sensor_frame: laser, data_type: LaserScan, topic: scan, marking: true, clearing: true, expected_update_rate: 0.5}

If you are still having issues, please post the rest of your configuration file. Not a lot of info was given to figure out your issues... Also, a screenshot of RXGRAPH would be nice alongside the output of this command:

rostopic info scan

Originally posted by allenh1 with karma: 3055 on 2012-07-20

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by pkohout on 2012-07-22:
have tried your configuration does't work. A picture of rxgrap : http://i.imgur.com/DBeHE.png

output of rostopic info scan:Type: sensor_msgs/LaserScan

Publishers:

  • /gazebo (http://peter-XPS-15Z:35525/)

Subscribers:

  • /hector_mapping (http://peter-XPS-15Z:50795/)

Comment by pkohout on 2012-07-22:
global_frame: /map robot_base_frame: base_link costmap/update_frequency: 0.2 costmap/static_map: true costmap/transform_tolerance: 1.0costmap/footprint: [[-0.3, -0.3], [-0.3, 0.3], [0.3, 0.3], [0.3, -0.3]] observation_sources: laser_scan_sensor

Comment by pkohout on 2012-07-22:
observation_sources: laser_scan_sensor

laser_scan_sensor: {sensor_frame: laser, data_type: LaserScan, topic: scan, marking: true, clearing: true, expected_update_rate: 0.5}

the whole config

Comment by pkohout on 2012-07-23:
ok found my fault..i was setting observation_sources: laser_scan_sensor wrong.. now it works. but now i get an error, [ERROR] [13, 5.46]: Client [/costmap_node] wants topic /scan to have datatype/md5sum [sensor_msgs/PointCloud/d8.. bur our version has sensor_msgs/LaserScan[...] drop connectino

Comment by allenh1 on 2012-07-23:
Please post your configuration file again... I think you have a data type issue.

Comment by pkohout on 2012-07-23:
ok was looking at my file once again and there was realy a little issue, i forgot to delete my laser_scan_sensor entry. thanks a lot dude (:

Comment by pkohout on 2012-07-23:
global_frame: /map

robot_base_frame: base_link

costmap:

update_frequency: 0.2

publish_frequency: 0.2

static_map: true

transform_tolerance: 1.0

footprint: [[-0.3, -0.3], [-0.3, 0.3], [0.3, 0.3], [0.3, -0.3]]

observation_sources: laser_scan_sensor

Comment by pkohout on 2012-07-23:
laser_scan_sensor: {sensor_frame: laser, data_type: LaserScan, topic: scan, marking: true, clearing: true, expected_update_rate: 0.5}

take a look at it...maybe there is somthing wrong i don't see

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.