0
$\begingroup$

Rosanswers logo

I'm running an application on two computers. The ROS_MASTER_URI on both is set to the master, and each ROS_HOSTNAME is set to itself. A node on the master computer subscribes to a topic /CmdController, which multiple nodes publish. However the node will only receive messages sent from other nodes on the master. When running 'rostopic echo /CmdController' on the master the computer it will print the messages sent from the other computer. Also rxgraph, run on the master, will show the nodes run on the other computer publishing /CmdController to the node running 'rostopic echo.' However, the actual connection between the one particular node on the master and any node run on the other computer is not formed. Any idea what would be causing this connection to not be formed?


Originally posted by Rorry_Brenner on ROS Answers with karma: 11 on 2012-07-12

Post score: 1


Original comments

Comment by Rorry_Brenner on 2012-07-12:
Don't have enough karma to comment on your answer. But yes, master and slave can ping eachother using either hostname or IP. I just tried setting ROS_IP instead and it looks like that fixed it anyway though. Thanks for the help!

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Can you ping the slave computer from the master when using the hostname and the other way around? Try setting ROS_IP instead of ROS_HOSTNAME, just to be sure.


Originally posted by Lorenz with karma: 22731 on 2012-07-12

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.