0
$\begingroup$

Rosanswers logo

Hi, I bought turtlebot full kit and am trying to move it.
However, I got some errors in this tutorial(Looking at Camera Data : http://www.ros.org/wiki/turtlebot/Tutorials/Looking%20at%20Camera%20Data).
I couldn't launch rviz with Asus EeePC. How do I solve it ?

I'm using Asus EeePC 1215B(This is a default PC for turtlebot).
It has Ubuntu 10.04 and ros electric.
I've already confirmed that turtlebot can be moved by teleoperation(turtlebot_teleop), so I think RobotSetup is correctly done.

I found one of the solution here(http://answers.ros.org/question/2109/rviz-in-ros-electric?answer=3627#3627), but I couldn't understand how to solve it in my case because of different configuration.

Here, I show the log data including four results.

  1. terminal error1 : rosrun rviz rviz (on turtlebot laptop)
  2. Ogre.log : got by the command "rosrun rviz rviz -l" (on turtlebot laptop)
  3. terminal error2 : rosrun rviz rviz (on workstation)
  4. troubleshooting : the result I got when I followed this page(http://answers.ros.org/question/2109/rviz-in-ros-electric?answer=3627#3627)

Thanks in advance.

///////////////////////////////////////
//terminal error (on turtlebot laptop)
///////////////////////////////////////
turtlebot@turtlebot-laptop:~$ rosrun rviz rviz
  [ INFO] [1341794677.953849619]: rviz revision number 1.6.7
  [ INFO] [1341794677.954535142]: ogre_tools revision number 1.6.3
  [ INFO] [1341794677.954618092]: compiled against OGRE version 1.7.3 (Cthugha)
  [ INFO] [1341794678.717732142]: Loading general config from [/home/turtlebot/.rviz/config]
  [ INFO] [1341794678.718407144]: Loading display config from [/home/turtlebot/.rviz/display_config]
  [ INFO] [1341794678.869544354]: RTT Preferred Mode is PBuffer.
  [ERROR] [1341794678.945262186]: Caught exception while loading: OGRE EXCEPTION(3:RenderingAPIException): Unable to create a suitable GLXContext in GLXContext::GLXContext at /tmp/buildd/ros-electric-visualization-common-1.6.3/debian/ros-electric-visualization-common/opt/ros/electric/stacks/visualization_common/ogre/build/ogre_src_v1-7-3/RenderSystems/GL/src/GLX/OgreGLXContext.cpp (line 61)

////////////////////////////////
//Ogre.log (on turtlebot laptop)
////////////////////////////////
09:50:26: Creating resource group General
09:50:26: Creating resource group Internal
09:50:26: Creating resource group Autodetect
09:50:26: SceneManagerFactory for type 'DefaultSceneManager' registered.
09:50:26: Registering ResourceManager for type Material
09:50:26: Registering ResourceManager for type Mesh
09:50:26: Registering ResourceManager for type Skeleton
09:50:26: MovableObjectFactory for type 'ParticleSystem' registered.
09:50:26: OverlayElementFactory for type Panel registered.
09:50:26: OverlayElementFactory for type BorderPanel registered.
09:50:26: OverlayElementFactory for type TextArea registered.
09:50:26: Registering ResourceManager for type Font
09:50:26: ArchiveFactory for archive type FileSystem registered.
09:50:26: ArchiveFactory for archive type Zip registered.
09:50:26: DDS codec registering
09:50:26: FreeImage version: 3.10.0
09:50:26: This program uses FreeImage, a free, open source image library supporting all common bitmap formats. See http://freeimage.sourceforge.net for details
09:50:26: Supported formats: bmp,ico,jpg,jif,jpeg,jpe,jng,koa,iff,lbm,mng,pbm,pbm,pcd,pcx,pgm,pgm,png,ppm,ppm,ras,tga,targa,tif,tiff,wap,wbmp,wbm,psd,cut,xbm,xpm,gif,hdr,g3,sgi,exr,j2k,j2c,jp2
09:50:26: Registering ResourceManager for type HighLevelGpuProgram
09:50:26: Registering ResourceManager for type Compositor
09:50:26: MovableObjectFactory for type 'Entity' registered.
09:50:26: MovableObjectFactory for type 'Light' registered.
09:50:26: MovableObjectFactory for type 'BillboardSet' registered.
09:50:26: MovableObjectFactory for type 'ManualObject' registered.
09:50:26: MovableObjectFactory for type 'BillboardChain' registered.
09:50:26: MovableObjectFactory for type 'RibbonTrail' registered.
09:50:26: OGRE EXCEPTION(6:FileNotFoundException): 'plugins.cfg' file not found! in ConfigFile::load at /tmp/buildd/ros-electric-visualization-common-1.6.3/debian/ros-electric-visualization-common/opt/ros/electric/stacks/visu
alization_common/ogre/build/ogre_src_v1-7-3/OgreMain/src/OgreConfigFile.cpp (line 83)
09:50:26: plugins.cfg not found, automatic plugin loading disabled.

09:50:26: --* OGRE Initialising
09:50:26: --* Version 1.7.3 (Cthugha)
09:50:26: Loading library RenderSystem_GL
09:50:26: Installing plugin: GL RenderSystem
09:50:26: OpenGL Rendering Subsystem created.
09:50:26: Plugin successfully installed
09:50:26: Loading library Plugin_OctreeSceneManager
09:50:26: Installing plugin: Octree & Terrain Scene Manager
09:50:26: Plugin successfully installed
09:50:26: Loading library Plugin_ParticleFX
09:50:26: Installing plugin: ParticleFX
09:50:26: Particle Emitter Type 'Point' registered
09:50:26: Particle Emitter Type 'Box' registered
09:50:26: Particle Emitter Type 'Ellipsoid' registered
09:50:26: Particle Emitter Type 'Cylinder' registered
09:50:26: Particle Emitter Type 'Ring' registered
09:50:26: Particle Emitter Type 'HollowEllipsoid' registered
09:50:26: Particle Affector Type 'LinearForce' registered
09:50:26: Particle Affector Type 'ColourFader' registered
09:50:26: Particle Affector Type 'ColourFader2' registered
09:50:26: Particle Affector Type 'ColourImage' registered
09:50:26: Particle Affector Type 'ColourInterpolator' registered
09:50:26: Particle Affector Type 'Scaler' registered
09:50:26: Particle Affector Type 'Rotator' registered
09:50:26: Particle Affector Type 'DirectionRandomiser' registered
09:50:26: Particle Affector Type 'DeflectorPlane' registered
09:50:26: Plugin successfully installed
09:50:26: Loading library Plugin_CgProgramManager
09:50:26: Installing plugin: Cg Program Manager
09:50:26: Plugin successfully installed
09:50:26: CPU Identifier & Features
09:50:26: -------------------------
09:50:26: * CPU ID: AuthenticAMD: AMD E-450 APU with Radeon(tm) HD Graphics
09:50:26: * SSE: yes
09:50:26: * SSE2: yes
09:50:26: * SSE3: yes
09:50:26: * MMX: yes
09:50:26: * MMXEXT: yes
09:50:26: * 3DNOW: no
09:50:26: * 3DNOWEXT: no
09:50:26: * CMOV: yes
09:50:26: * TSC: yes
09:50:26: * FPU: yes
09:50:26: * PRO: yes
09:50:26: * HT: no
09:50:26: -------------------------
09:50:26: ****************************** *** Starting GLX Subsystem *** ******************************
09:50:26: Creating resource group ogre_tools
09:50:26: Added resource location '/opt/ros/electric/stacks/visualization_common/ogre_tools/media' of type 'FileSystem' to resource group 'ogre_tools'
09:50:26: Added resource location '/opt/ros/electric/stacks/visualization_common/ogre_tools/media/fonts' of type 'FileSystem' to resource group 'ogre_tools'
09:50:26: Added resource location '/opt/ros/electric/stacks/visualization_common/ogre_tools/media/models' of type 'FileSystem' to resource group 'ogre_tools'
09:50:26: Added resource location '/opt/ros/electric/stacks/visualization_common/ogre_tools/media/materials' of type 'FileSystem' to resource group 'ogre_tools'
09:50:26: Added resource location '/opt/ros/electric/stacks/visualization_common/ogre_tools/media/materials/scripts' of type 'FileSystem' to resource group 'ogre_tools'
09:50:26: Added resource location '/opt/ros/electric/stacks/visualization_common/ogre_tools/media/materials/programs' of type 'FileSystem' to resource group 'ogre_tools'
09:50:26: GLRenderSystem::_createRenderWindow "OgreRenderWindow1", 1024x768 windowed miscParams: macAPI=carbon parentWindowHandle=73400362
09:50:27: OGRE EXCEPTION(3:RenderingAPIException): Unable to create a suitable GLXContext in GLXContext::GLXContext at /tmp/buildd/ros-electric-visualization-common-1.6.3/debian/ros-electric-visualization-common/opt/ros/elect
ric/stacks/visualization_common/ogre/build/ogre_src_v1-7-3/RenderSystems/GL/src/GLX/OgreGLXContext.cpp (line 61)

//////////////////////////////////
//terminal error (I typed the following command after I remotely logged in turtlebot laptop using ssh.)
//////////////////////////////////
turtlebot@turtlebot-laptop:~$ rosrun rviz rviz
  Error: Unable to initialize gtk, is DISPLAY set properly?

///////////////////////////////////////////////
//trouble shooting (on turtlebot laptop)
///////////////////////////////////////////////
turtlebot@turtlebot-laptop:~$ glxinfo | grep version
  server glx version string: 1.2
  client glx version string: 1.4
  GLX version: 1.2
  OpenGL version string: 1.4 (2.1 Mesa 7.7.1)

turtlebot@turtlebot-laptop:~$ roscd rviz ; ldd bin/rviz | grep libGL
  libGL.so.1 => /usr/lib/mesa/libGL.so.1 (0x00007f64b43df000)
  libGLU.so.1 => /usr/lib/libGLU.so.1 (0x00007f64b416e000)

turtlebot@turtlebot-laptop:/opt/ros/electric/stacks/visualization/rviz$ ls -l /usr/lib/mesa/libGL.so.1
  lrwxrwxrwx 1 root root 12 2012-02-14 23:33 /usr/lib/mesa/libGL.so.1 -> libGL.so.1.2

turtlebot@turtlebot-laptop:/opt/ros/electric/stacks/visualization/rviz$ ls -l /usr/lib/mesa/libGL.so.1.2
  -rw-r--r-- 1 root root 527200 2010-04-29 14:54 /usr/lib/mesa/libGL.so.1.2

turtlebot@turtlebot-laptop:/opt/ros/electric/stacks/visualization/rviz$ ls /usr/lib/mesa
  ld.so.conf libGL.so libGL.so.1 libGL.so.1.2

turtlebot@turtlebot-laptop:/opt/ros/electric/stacks/visualization/rviz$ cd /usr/lib/nvidia turtlebot@turtlebot-laptop:/usr/lib/nvidia$ ls
  pre-install

additional information
Laptop on turtlebot(I call 'turtlebot laptop' here)
  Asus EeePC 1215B (Ubuntu10.04, ROS Electric)(This PC cannot launch rviz.)
and driver is default one...
turtlebot@turtlebot-laptop:~@lspci | grep VGA
  00:01.0 VGA compativle controller: ATI Technologies Inc Device 9806
(I'm sorry I don't know how to check the version. How can I do it?)

Laptop in remote place(I call 'workstation' here)
  Dell Latitude E6510 Ubuntu10.04, ROS Electric) (This PC has a video card called nVidia NVS 3100M and is installed nVidia driver. It could launch rviz if it were alone.)


Originally posted by moyashi on ROS Answers with karma: 721 on 2012-07-08

Post score: 0


Original comments

Comment by ipso on 2012-07-08:
Could you please reformat your posting? For terminal output please prefix all lines with ' ' (four spaces) to preserve its formatting. A blockquote (prefix lines with a '>') is also acceptable. See markdown/syntax for more information.

Comment by moyashi on 2012-07-09:
Thank you for your advice, ipso. I made it and added some info.If it doesn't look good, please say it.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

rviz needs a working OpenGL setup, which means you need a proper installation of the drivers of your graphics card. The Radeon of the EeePC 1215B should be capable of running rviz, but it most likely needs the proprietary AMD drivers for it (the open-source drivers don't provide sufficient 3D acceleration as of this time AFAIK).

The output of glxinfo you posted indicates that you're currently making use of the default Mesa drivers, which is insufficient for rviz / OpenGL.

EDIT3: all wrong, OpenGL was working, OGRE needed OGRE_RTT_MODE=Copy again. See @weiin's answer (and the comments).


EDIT:

//terminal result (on workstation)
turtlebot@turtlebot-laptop:~$ rosrun rviz rviz Error: Unable to initialize 
gtk, is DISPLAY set properly?

Is this in a SSH session from your workstation to the EeePC? If so, this error is 'normal': your SSH session has no access to any running X instances.


EDIT2: Perhaps you should provide some more info on your setup. Which drivers have you installed, and which versions are they? What OS are you running? etc


Originally posted by ipso with karma: 1416 on 2012-07-08

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by weiin on 2012-07-08:
I don't think the default Mesa drivers are insufficient. My glxinfo output is the same (OpenGL version string: 2.1 Mesa 7.7.1) and I run rviz quite fine. Running 'glxgears' should show whether OpenGL can work on the current drivers

Comment by ipso on 2012-07-08:
Ok, that's why I added that my comment was 'as far as I know'. Perhaps you could post some more information on your setup (if it is relevant)?

Comment by moyashi on 2012-07-09:
Thank you for your comments, ipso and weiin.

Is this in a SSH session ... ? Yes, exactly. Thank you, I got it.

Which drivers ... ? I added some infor the bottom of the above sentences.

I ran 'glxgears' and it worked well.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.