Rosanswers logo

Hi all, I want to run the simulation http://www.ros.org/wiki/urdf/Tutorials/Building%20a%20Visual%20Robot%20Model%20with%20URDF%20from%20Scratch

but as soon as i run command

roslaunch urdf_tutorial display.launch model:=01-myfirst.urdf

it gives me errors as listed below

process[rviz-3]: started with pid [8013]

Config file '/home/sanket/.rviz/config' could not be opened for reading.

Xlib: extension "GLX" missing on display ":0.0".

rviz::RenderSystem: error creating render window: std::exception

[ERROR] [1341773552.827124051]: Unable to create the rendering window after 100 tries.

rviz: /tmp/buildd/ros-fuerte-visualization-1.8.13/debian/ros-fuerte-visualization/opt/ros/fuerte/stacks/visualization/rviz/src/rviz/ogre_helpers/render_system.cpp:263: Ogre::RenderWindow* rviz::RenderSystem::makeRenderWindow(intptr_t, unsigned int, unsigned int): Assertion `false' failed.

[rviz-3] process has died [pid 8013, exit code -6, cmd /opt/ros/fuerte/stacks/visualization/rviz/bin/rviz -d /opt/ros/fuerte/stacks/robot_model_tutorials/urdf_tutorial/urdf.vcg __name:=rviz __log:=/home/sanket/.ros/log/5e4ebc6c-c928-11e1-950f-848f69c0fd9c/rviz-3.log].

log file: /home/sanket/.ros/log/5e4ebc6c-c928-11e1-950f-848f69c0fd9c/rviz-3*.log

i don't know whether my rviz is missing some files or is it related to system requirements of my laptop

Originally posted by Sanket_Kumar on ROS Answers with karma: 234 on 2012-07-08

Post score: 2

Original comments

Comment by ipso on 2012-07-08:
Could you please reformat your question? Using code formatting or blockquotes makes console output much more readable (see here for some pointers). Thanks.


2 Answers 2


Rosanswers logo

It seems your X configuration is not properly set up for 3D accelerated OpenGL operation. GLX is the 'OpenGL Extension to the X Window System', which is required for this.

It seems you have more problems with this particular machine / setup? I noticed this question, which seems to be related.

I'd first sort out the OpenGL / Xorg setup on the machine (without involving ROS or rviz) and then try to tackle the rviz problems.

Originally posted by ipso with karma: 1416 on 2012-07-08

This answer was ACCEPTED on the original site

Post score: 1


Rosanswers logo

i also got similar error. i followed following steps:

  1. install nvidia drivers from ubuntu software centre.

  2. use additional driver utility to check if any driver is missing. In mine it showed nvidia drivers not active.So activate it and restart.

Originally posted by akash_b with karma: 31 on 2014-05-19

This answer was NOT ACCEPTED on the original site

Post score: 3

Original comments

Comment by PaulBouchier on 2014-07-27:
More specifically, to run the additional driver utility, type "Additional Drivers" in the Ubuntu Dash and select the additional drivers application. It starts a dialog that looks to see which additional drivers are installed and active. I found that the nvidia drivers were installed (because I installed them when I installed Ubuntu), but were not active. I pressed the "Activate" button for both the driver and the post-install update, rebooted after it was done installing/activating, and rviz suddenly worked.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.