0
$\begingroup$

Rosanswers logo

Hi !

i am new to ros, i installed ros fuerte few days back, the version of opencv installed with ros was 2.4.0, now opencv 2.4.2 has been released, i want to upgrade my current opencv 2.4.0 to opencv 2.4.2, how can i do that ?

regards

usama


Originally posted by usamayaseen on ROS Answers with karma: 69 on 2012-07-07

Post score: 1


Original comments

Comment by usamayaseen on 2012-07-07:
The reason to migrate to opencv 2.4.2 is new Face Recognition implementations available in opencv 2.4.2: http://docs.opencv.org/trunk/modules/contrib/doc/facerec/facerec_tutorial.html#eigenfaces-in-opencv .

Comment by ZoltanS on 2013-05-01:
I also need to update OpenCV in Groovy. I use ROS Groovy with OpenCV 2.4.4 and I would need to use v.2.4.5 since v.2.4.4 has some issue with camera calibration (see http://answers.ros.org/question/57240/camera-calibration-crashes/).

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi Usama,

Is there any particular reason for which you would want to upgrade to OpenCV2.4.2. I have been working with the current OpenCV2.4.0 and it works fine for all the features I would need.

Other than that if you have automatic updates ON the right updates will be automatically installed. You may even manually run the Update manager to see if it shows OpenCV2.4.2 as an update for ROS.

Note that if you have not added ROS into your repository lists, which I believe you must have done during installation, you may have to do it for the update manager to provide you with the updates. This can be done using the first few steps in the installation of ROS provided in the following link:

ROS Installation Link

Regards,


Originally posted by SivamPillai with karma: 612 on 2012-07-07

This answer was ACCEPTED on the original site

Post score: -1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.