0
$\begingroup$

Rosanswers logo

I'm having trouble with mapping... I have both the laser scan and odometry from a bagfile. When I run the laser scan trough a node (doesn't change any data, just converts to a pointcloud) and convert back to a laserscan with poincloudtolaser, it will not map from the new topic.

I'm sure this has something to do with the base_link or some frame_id thing, but I have no idea how to set this up... Any help?


The published scan has a different laser topic. It is /laserOut/filtered (again, no filtering yet). So, I run gmapping with the following:

rosrun gmapping slam_gmapping _particles:=100 _linearUpdate:=0.1 _angularUpdate:=0.1 scan:=/laserOut/filtered

This accounts for the update interval and points at the topic to listen to. Gmapping is not having trouble with scan matching. It scores like it does normally. The only difference is the fact that it does not update the map after.


Originally posted by allenh1 on ROS Answers with karma: 3055 on 2012-07-04

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi, normaly the TF (or as you called it frame_id think ;-) ) for a laser scan message is by default "/laser" and the topic name is "/scan". With

rostopic list 

you can check if the topic name "/scan" is available. If yes the just check by

rostopic echo /scan

if the header of the message contains the correct default frame_id. Alternatively you can also try

roswtf

and check the results.


Originally posted by tlinder with karma: 663 on 2012-07-04

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by allenh1 on 2012-07-05:
All is as it should be there... What would cause GMapping to scan match and score highly, but not update the map?

Comment by tlinder on 2012-07-05:
As far as i remember was there a parameter for setting up the map updated ratio, i.e. the parameter after how many meters or change in degree shall the map be republished. May this helps.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.