0
$\begingroup$

Rosanswers logo

I've cloned the PCL sources (for PCL 1.5) from https://github.com/wg-debs/pcl in my ROS_WORKSPACE and renamed it as pcl.

I cannot compile pcl1.5 in my ROS_WORKSPACE. With "$ roscd pcl" my current directory changes to /opt/ros/fuerte/share/pcl which is not in my ROS_WORKSPACE.

I want to just make an executable file i.e. openni_viewer in my ROS_WORKSPACE/pcl/visualization/tools and execute that.

In the CMakeList.txt in the directory "pcl/visualization/tools" there is a instruction for that... PCL_ADD_EXECUTABLE(openni_viewer ${SUBSYS_NAME} openni_viewer.cpp) target_link_libraries(openni_viewer pcl_common pcl_io pcl_kdtree pcl_visualization)

But it is not compiled with $ rosmake pcl (I cannot get a binary executable file from pcl/viaualization/tools/openni_viewer.cpp)

Earler, I used to clone the stack "perception_pcl_addons" to my ROS_PACKAGE_PATH and just $ rosmake pcl_visualization (using previous versions of ROS) which then created a binary executable file openni_viewer.

Do you have any suggestions?

My confituration: ROS fuerte, Ubuntu 11.10

with best regards, oli


Originally posted by OliR on ROS Answers with karma: 21 on 2012-06-29

Post score: 2


Original comments

Comment by dinamex on 2012-08-29:
did you get it working? I'm still looking for a solution to compile a ros supported pcl version.

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

The PCL sources in https://github.com/wg-debs/pcl do not contain a ROS package. That is why roscd cannot find them and rosmake cannot make them.

Those sources were apparently used to create the ros-fuerte-pcl Debian package for the supported Ubuntu versions (Lucid, Oneiric, and Precise). To build them on another system, look inside the Debian rules to see how to build it.

Probably, it looks similar to a normal stand-alone PCL build, but with the USE_ROS parameter set. The following is my best guess:

$ mkdir build
$ cd build
$ cmake .. -DUSE_ROS=1
$ make 
$ sudo make install

Please let us know what actually works for you.


Originally posted by joq with karma: 25443 on 2012-09-06

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$
0
$\begingroup$

Rosanswers logo

You still need to set ROS_PACKAGE_PATH. Do a

$ export ROS_PACKAGE_PATH=/path/to/pcl:$ROS_PACKAGE_PATH 
$ roscd pcl

Originally posted by bhaskara with karma: 1479 on 2012-06-29

This answer was NOT ACCEPTED on the original site

Post score: 2


Original comments

Comment by OliR on 2012-07-01:
Thank you for your answer But I've already set my ROS_PACKAGE_PATH as my private directory and in that directory locate the pcl package.

I set my ROS_PACKAGE_PATH and my ROS_WORKSPACE as follow $ export ROS_PACKAGE_PATH=~/ros:$ROS_PACKAGE_PATH $ export ROS_WORKSPACE=~/ros

Comment by OliR on 2012-07-01:
And the package "pcl" is in my directory ~/ros/. There are also other stacks and packages. With $ roscd STACK or PACKAGE changes my current directory to ~/ros/STACK or PACKAGE. BUT it is not working only for the "pcl". $ roscd pcl indicate always /opt/ros/fuerte/share. Do u have any idea?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.