0
$\begingroup$

Rosanswers logo

what is the communication between the following frame?

Base on my understanding, I'll assume the parent-child relationship as below

Parent ----> child

--- ----> map (map_frame)

map ----> nav (odom_frame)

nav ----> base_footprint (base_frame)

base_footprint ----> base_stabilized

base_stabilized ----> base_link

base_link ----> laser

Is this above relationship correct?

Since I'm gonna implement on the UAV...... The problems that i'm getting are the following :

[lookupTransform base_footprint to laser timed out. Could not transform laser scan into base_frame.]

what is the link between nav--->base_stabilized? how to tf it?

what should i set the base_frame to? base_stabilized or based_footprint?

Finally do you have any suggestion/ideas that how all the tf for the large angle change and have roll/pitch movement of the UAV should link together?

(Thank in advanced for your helping) :D


Originally posted by jas on ROS Answers with karma: 33 on 2012-06-26

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi, I assume you checked this How-To-Do for setting up the TFs.

what is the link between nav--->base_stabilized? how to tf it?

In cases where you to not have any odometry (UAV and so on) this frame is equal to base_stabilized and you can set it up this way:

<param name="pub_map_odom_transform" value="true"/>
<param name="map_frame" value="map" />
<param name="base_frame" value="base_frame" />
<param name="odom_frame" value="base_frame" />

We also use Hector on UAVs (Octocopters, result video here). The our default Launch configuration is below:

<launch>
<node pkg="hector_mapping" type="hector_mapping" name="hector_mapping" output="screen">
<param name="base_frame" value="base_stabilized" />
<param name="odom_frame" value="base_stabilized"/>
<param name="output_timing" value="false"/>
<param name="use_tf_scan_transformation" value="true"/>
<param name="use_tf_pose_start_estimate" value="false"/>
<param name="scan_topic" value="scan"/>
<!-- Map size / start point -->
<param name="map_resolution" value="0.025"/>
<param name="map_size" value="2048"/>
<param name="map_start_x" value="0.5"/>
<param name="map_start_y" value="0.5" />
<param name="laser_z_min_value" value="-2.5" />
<param name="laser_z_max_value" value="3.5" />
<!-- Map update parameters -->
<param name="update_factor_free" value="0.4"/>
<param name="update_factor_occupied" value="0.7" />    
<param name="map_update_distance_thresh" value="0.2"/>
<param name="map_update_angle_thresh" value="0.06" />
<param name="pub_map_odom_transform" value="true"/>
<!--
<param name="pub_drawings" value="true"/>
<param name="pub_debug_output" value="true"/>
-->
</node>
<param name="hector_mapping/pub_map_odom_transform" value="true"/>
<include file="$(find hector_geotiff)/launch/geotiff_mapper.launch" />
</launch>

Hope this solves your issues.


Originally posted by tlinder with karma: 663 on 2012-06-26

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by jas on 2012-07-01:
I've set the setting as above but i've got the result as this link http://www.youtube.com/watch?v=bGbPJkq8Wdg&feature=youtu.be . I was tested out with all the processing thing put on the platform at the stationary point but move in large angle and turning which is as in video... the axis in the rviz drifted around and sometime it move out of the grid..then on the terminal it shown "search angle too large"..so that it make the map not accurate at all.. can you suggest any idea to fix the problem? (Thanks for your help :D really appreciate it)

Comment by tlinder on 2012-07-01:
Ok, i see. First of all, the radical movements you are performing in the video are literally extreme and so i do not wonder that the search angle is to large. Just think about a robot which is performing such movements, most likely this robot will get sick and mad ;-)

Comment by tlinder on 2012-07-01:
But back to the problem. If a robot needs to perform so fast movements it needs to get also its sensor data fast and precise. Hector and the Hokuyo updated with ca. 30-50 Hz wich is enough for standard UAV movemenst. If the robot needs to move faster you may need a faster scanner or

Comment by tlinder on 2012-07-01:
more orthogonal data, i.e. sensor data about your movement from a different source. In cases of UAVs but also UGVs Inertial Measurement Units (IMUs) are one of such sensors. The IMU then is in minimum giving you a orientation estimation. Hector can be feed with such data as a odomentry.

Comment by jas on 2012-07-01:
Thanks for your information.... i know that it move a bit too fast :D haha but just to say that we are gonna to put it on the UAV, we afraid that it will be too sensitive that it drift outside of the grid....

Comment by jas on 2012-07-01:
sorry to bother you again..just now i'm tested with the resonable speed which we think UAV might behave with handhold...as shown in this video.http://www.youtube.com/watch?v=eVlrnUQAEn8 but the drifting of the axis is as sensitive as usual,

Comment by jas on 2012-07-02:
i have no idea to solve it...any suggestion which we could stablized the axis...(Thanks for you help :D)

Comment by tlinder on 2012-07-02:
Ok is see pleas can you make a bag file and run Hector on a regular PC. I have the feeling that your embedded PC which you are using is not really pulling the full 40 Hz of the scanner or is to slow to deal with them. Is there any other process running? If you make the bag available i may test it.

Comment by jas on 2012-07-02:
the embedded PC(500 MHz/LX600 366 MHz processor) only running the hector, imu and hokuyo packages and i have recorded the .bag file which run on the regular PC here is my .bag file http://code.google.com/p/hectormapping/downloads/list

Comment by jas on 2012-07-02:
http://code.google.com/p/hectormapping/downloads/list (Thanks for your help)

Comment by jas on 2012-07-04:
I have testing out one problem associate with the drifting in rviz... which is whenever i put my hand very close to my laser scanner, the drifting occur dramatically and SearchDir angle change too large appear a lot. is there any thing i can do? (Thanks in advance)

Comment by elva on 2013-03-25:
hi ,have solved your problem , i also got problems using hector mapping with laser scanner, my hector mapping in rviz is not accurate at all,it overlaps,is there anything i can do about it?

Comment by hashim on 2016-04-24:
Hi tlinder, can you tell me how can i give imu data to hector_mapping node ? its been days i couldnt solve my problem... help me please

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.