0
$\begingroup$

Rosanswers logo

I m trying to use Rgbdslam on Ubuntu 12.04 LTS and ROS Fuerte however I am a beginner in ROS and I can't figure it out how to make that work.

I did tthe followings steps :

  1. Installed Ubuntu 12.04 LTS 64bit version

  2. Installed ROS Fuerte (sudo apt-get install ros-electric-fuerte-full)

  3. echo "source /opt/ros/electric/setup.bash" >> ~/.bashrc

  4. . ~/.bashrc

  5. Installed QT Creator via Ubuntu Software Center

  6. Setup RGBDSLAM again as per http://www.ros.org/wiki/rgbdslam

a. mkdir -p ~/ros

b. echo 'export ROS_PACKAGE_PATH=~/ros:$ROS_PACKAGE_PATH' >> ~/.bashrc

c. source ~/.bashrc

d. svn co http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg/rgbdslam

e. svn co https://code.ros.org/svn/ros-pkg/stacks/vslam/trunk/g2o ~/ros/g2o

f. rosdep install rgbdslam

And it failed directly :

alban:~/ros$ rosdep install rgbdslam
ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
rgbdslam: Cannot locate rosdep definition for [qt4]

I suppose that I don't just have to install QT Creator, maybe I have to do some more stuff but I didn't success to find this information. Does anyone can help me ?

[ I ve tried also to install the advices following librairies : "sudo apt-get install libglew1.5-dev libdevil-dev libsuitesparse-dev"

No problem And when I type

alban:~/ros$ update-alternatives --display qmake

I get:

qmake - mode automatique
 le lien pointe actuellement sur /usr/bin/qmake-qt4
/usr/bin/qmake-qt4 - priorité 40
 lien secondaire qmake.1.gz : /usr/share/man/man1/qmake-qt4.1.gz
La « meilleure » version actuelle est « /usr/bin/qmake-qt4 ».

]

I tried to compile directly:

alban:~$ rosmake rgbdslam
[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['rgbdslam']                                
[ rosmake ] Logging to directory /home/alban/.ros/rosmake/rosmake_output-20120620-124759
[ rosmake ] Expanded args ['rgbdslam'] to:
['rgbdslam']                         
[rosmake-0] Starting >>> bullet [ make ]                                        
[rosmake-1] Starting >>> geometry_msgs [ make ]                                 
[rosmake-0] Finished <<< bullet ROS_NOBUILD in package bullet                   
[rosmake-1] Finished <<< geometry_msgs  No Makefile in package geometry_msgs    
[rosmake-0] Starting >>> roslang [ make ]                                       
[rosmake-1] Starting >>> sensor_msgs [ make ]                                   
[rosmake-0] Finished <<< roslang  No Makefile in package roslang                
[rosmake-0] Starting >>> roscpp [ make ]                                        
[rosmake-1] Finished <<< sensor_msgs  No Makefile in package sensor_msgs        
[rosmake-1] Starting >>> rosconsole [ make ]                                    
[rosmake-0] Finished <<< roscpp  No Makefile in package roscpp                  
[rosmake-0] Starting >>> angles [ make ]                                        
[rosmake-1] Finished <<< rosconsole  No Makefile in package rosconsole          
[rosmake-1] Starting >>> rospy [ make ]                                         
[rosmake-0] Finished <<< angles ROS_NOBUILD in package angles                   
[rosmake-0] Starting >>> rostest [ make ]                                       
[rosmake-1] Finished <<< rospy  No Makefile in package rospy                    
[rosmake-1] Starting >>> roswtf [ make ]                                        
[rosmake-1] Finished <<< roswtf  No Makefile in package roswtf                  
[rosmake-1] Starting >>> message_filters [ make ]                               
[rosmake-1] Finished <<< message_filters  No Makefile in package message_filters
[rosmake-0] Finished <<< rostest  No Makefile in package rostest                
[rosmake-0] Starting >>> std_msgs [ make ]                                      
[rosmake-1] Starting >>> tf [ make ]                                            
[rosmake-1] Finished <<< tf ROS_NOBUILD in package tf                           
[rosmake-1] Starting >>> rosbag [ make ]                                        
[rosmake-1] Finished <<< rosbag  No Makefile in package rosbag                  
[rosmake-0] Finished <<< std_msgs  No Makefile in package std_msgs              
[rosmake-0] Starting >>> pcl [ make ]                                           
[rosmake-1] Starting >>> rosbuild [ make ]                                      
[rosmake-1] Finished <<< rosbuild  No Makefile in package rosbuild              
[rosmake-1] Starting >>> roslib [ make ]                                        
[rosmake-1] Finished <<< roslib  No Makefile in package roslib                  
[rosmake-1] Starting >>> pluginlib [ make ]                                     
[rosmake-1] Finished <<< pluginlib ROS_NOBUILD in package pluginlib             
[rosmake-0] Finished <<< pcl  No Makefile in package pcl                        
[rosmake-0] Starting >>> bond [ make ]                                          
[rosmake-0] Finished <<< bond ROS_NOBUILD in package bond                       
[rosmake-0] Starting >>> smclib [ make ]                                        
[rosmake-0] Finished <<< smclib ROS_NOBUILD in package smclib                   
[rosmake-0] Starting >>> bondcpp [ make ]                                       
[rosmake-0] Finished <<< bondcpp ROS_NOBUILD in package bondcpp                 
[rosmake-0] Starting >>> rosservice [ make ]                                    
[rosmake-0] Finished <<< rosservice  No Makefile in package rosservice          
[rosmake-1] Starting >>> nodelet [ make ]                                       
[rosmake-1] Finished <<< nodelet ROS_NOBUILD in package nodelet                 
[rosmake-1] Starting >>> common_rosdeps [ make ]                                
[rosmake-1] Finished <<< common_rosdeps ROS_NOBUILD in package common_rosdeps   
[rosmake-1] Starting >>> opencv2 [ make ]                                       
[rosmake-1] Finished <<< opencv2 ROS_NOBUILD in package opencv2                 
[rosmake-0] Starting >>> dynamic_reconfigure [ make ]                           
[rosmake-0] Finished <<< dynamic_reconfigure ROS_NOBUILD in package dynamic_reconfigure
[rosmake-0] Starting >>> nodelet_topic_tools [ make ]                           
[rosmake-1] Starting >>> cv_bridge [ make ]                                     
[rosmake-0] Finished <<< nodelet_topic_tools ROS_NOBUILD in package nodelet_topic_tools
[rosmake-0] Starting >>> pcl_ros [ make ]                                       
[rosmake-0] Finished <<< pcl_ros ROS_NOBUILD in package pcl_ros                 
[rosmake-1] Finished <<< cv_bridge ROS_NOBUILD in package cv_bridge             
[rosmake-0] Starting >>> camera_calibration_parsers [ make ]                    
[rosmake-1] Starting >>> image_transport [ make ]                               
[rosmake-0] Finished <<< camera_calibration_parsers ROS_NOBUILD in package camera_calibration_parsers
[rosmake-0] Starting >>> camera_info_manager [ make ]                           
[rosmake-1] Finished <<< image_transport ROS_NOBUILD in package image_transport 
[rosmake-1] Starting >>> image_geometry [ make ]                                
[rosmake-1] Finished <<< image_geometry ROS_NOBUILD in package image_geometry   
[rosmake-0] Finished <<< camera_info_manager ROS_NOBUILD in package camera_info_manager
[rosmake-0] Starting >>> openni_camera [ make ]                                 
[rosmake-0] Finished <<< openni_camera ROS_NOBUILD in package openni_camera     
[rosmake-1] Starting >>> hogman_minimal [ make ]                                
[rosmake-0] Starting >>> visualization_msgs [ make ]                            
[rosmake-0] Finished <<< visualization_msgs  No Makefile in package visualization_msgs
[rosmake-0] Starting >>> rgbdslam [ make ]                                      
[ rosmake ] All 21 linesogman_minimal: 1.0 sec ] ... [ 2 Active 35/37 Complete ]
{-------------------------------------------------------------------------------
  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
  [rosbuild] Building package rgbdslam
  Failed to invoke /opt/ros/fuerte/bin/rospack deps-manifests rgbdslam
  [rospack] Error: package/stack rgbdslam depends on non-existent package eigen
  
  
  CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:129 (message):
    
  
    Failed to invoke rospack to get compile flags for package 'rgbdslam'.  Look
    above for errors from rospack itself.  Aborting.  Please fix the broken
    dependency!
  
  Call Stack (most recent call first):
    /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack)
    CMakeLists.txt:31 (rosbuild_init)
  
  
  -- Configuring incomplete, errors occurred!
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package rgbdslam written to:
[ rosmake ]    /home/alban/.ros/rosmake/rosmake_output-20120620-124759/rgbdslam/build_output.log
[rosmake-0] Finished <<< rgbdslam [FAIL] [ 1.05 seconds ]                       
[ rosmake ] Halting due to failure in package rgbdslam. 
[ rosmake ] Waiting for other threads to complete.
[rosmake-1] Finished <<< hogman_minimal [PASS] [ 4.73 seconds ]                 
[ rosmake ] Results:                                                            
[ rosmake ] Built 37 packages with 1 failures.                                  
[ rosmake ] Summary output to directory                                         
[ rosmake ] /home/alban/.ros/rosmake/rosmake_output-20120620-124759    

after like 1 min it stop and seems not working:

alban:~$ rosrun rgbdslam rgbdslam
[rosrun] Couldn't find executable named rgbdslam below /home/alban/ros/rgbdslam
[rosrun] Found the following, but they're either not files, 
[rosrun] or not executable:

Originally posted by Absy on ROS Answers with karma: 43 on 2012-06-19

Post score: 0


Original comments

Comment by prince on 2012-06-19:
Did you installed Qt4 libraries? I do not know whether these gets installed as dependency packages for QT Creator! Check for correct version of Qt libraries.

Comment by Absy on 2012-06-20:
I think that I have installed QT4 libraries by doing this : alban:~$ sudo apt-get install libqt4-dev Reading package lists... Done Building dependency tree
Reading state information... Done libqt4-dev is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgrad

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Probably, the rosdep definition for qt4 is not defined for fuerte yet. That's not a fatal error though. Just ignore the rosdep install step and continue with building the rgbdslam stack.

It seems to me that the stack hasn't been ported to Fuerte yet since the rosdep definition for qt4 is unknown. That means there is a certain chance that you will run into compile problems.

Edit: Running rgbdslam is not working because you got a build error. As I said, rgbdslam doesn't seem to be ported to Fuerte yet. I actually suggest using Electric for now. The reason for the actual error you see is that eigen is no ros package anymore but a system dependency. You can try removing the dependency on it from rgbdslam's manifest.xml file.


Originally posted by Lorenz with karma: 22731 on 2012-06-20

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.