0
$\begingroup$

Rosanswers logo

Hi, I'm trying to acquire the point cloud from the simulated kinect in the Turtlebot. However, when I try to visualize the point cloud with rviz, the point cloud looks "flat", as if (almost) all the points got projected on a plane. On the right you can see a (small) image representing what the world actually is.

image description http://desmond.imageshack.us/Himg205/scaled.php?server=205&filename=senzatitolony.png&res=landing

I just followed the tutorial to simulate the turtlebot.

Anyone else faced a similar issue? Any suggestion?


Originally posted by Saphrosit on ROS Answers with karma: 197 on 2012-06-19

Post score: 2


Original comments

Comment by Yannis on 2012-07-03:
I am having exactly the same problem, and cannot figure out what is wrong. Some other answers say that it could be a problem of graphic card, which one are you using ?

Comment by Saphrosit on 2012-07-03:
@Yannis I tried first on a computer with nvidia geforce gt 520mx + intel graphic card integrated. Then I managed to make it work on a little bit older computer with nvidia geforce 200M. I installed drivers 295.53 (there were problems in installing the latest version).

Comment by Saphrosit on 2012-07-03:
@Yannis I tried also on a MacBookPro, launching Ubuntu on VMWare, but same problems. Actually I'm not 100% sure the problem is the graphic card (it means I don't know, not I don't think so), but once I got a working solution I didn't touch anything else for fear of crushing up everything :)

Comment by Yannis on 2012-07-04:
Ok, so it worked with the two Nvidia graphic card right ? I think I'll buy one, because I tried on a desktop that had integrated graphics and I got the same problem.

Comment by Saphrosit on 2012-07-04:
@Yannis Yes, but it worked with the nvidia geforce 200M, which is pretty old. It didn't with the nvidia geforce gt 520mx...I would suggest you to be sure before buying a graphic card, otherwise you may just waste money :)

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This is the same problem as mentioned in this thread: http://answers.ros.org/question/12150/problem-simulating-kinect-in-gazebo/


Originally posted by piyushk with karma: 2871 on 2013-01-04

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.