0
$\begingroup$

Rosanswers logo

Hi, I am using RGBDSLAM on a Ubuntu 11.10 machine, with ROS Electric installed. I am using a Kinect camera to get the video feed. When I open the rgbdslam GUI using:

rosrun rgbdslam rgbdslam

I can see the monochrome image and depth image, but on the top window, I am supposed to see the 'map', right? But what I see is basically the background wallpaper (the desktop) right through it. I am confused as to why this happens.

I also ran rviz, and so far it does say that I am subscribed to a pointcloud2. However, even in rviz I do not get to see a 'map' or a video feed, just a black background screen as set by default.

Can anyone help?


Originally posted by periphery on ROS Answers with karma: 21 on 2012-06-18

Post score: 2


Original comments

Comment by periphery on 2012-06-20:
@Felix Endres : I couldn't find the use_glwidget parameter in any launchfile. Which launchfile were you talking about specifically? I am in ros/rgbdslam/launch directory.

Comment by Felix Endres on 2012-06-20:
Have a look at the sample config: http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg/rgbdslam/launch/rgbdslam_sample_config.launch - It should contain all possible parameter in their default configuration.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Sounds like OpenGL problems. Either fix these, or use rgbdslam without 3D display by setting the parameter "use_glwidget" to "false" (e.g. in a launchfile).


Originally posted by Felix Endres with karma: 6468 on 2012-06-19

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.