0
$\begingroup$

Rosanswers logo

hi i am trying to install the joy driver i tried running the command rosdep install joy and got the following error what should I do? ERROR: Rosdep cannot find all required resources to answer your query Missing resource joy ROS path [0]=/opt/ros/fuerte/share/ros ROS path [1]=/home/lab/ros_workspace ROS path [2]=/opt/ros/fuerte/share ROS path [3]=/opt/ros/fuerte/stacks


Originally posted by gupta on ROS Answers with karma: 1 on 2012-06-07

Post score: 2


Original comments

Comment by gupta on 2012-06-07:
i am running it on 12.04 and my /.bashrc ros_package_ path is as follows: export ROS_PACKAGE_PATH=~/ros_workspace:/opt/ros/fuerte/share:/opt/ros/fuerte/stacks:/opt/ros/fuerte/share/ros:/home/lab/ros_workspace:/opt/ros/fuerte/share:/opt/ros/fuerte/stacks

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I believe you don't have the ROS joystick drivers installed. As a result, rosdep is unable to find the ROS package joy, and cannot resolve its system dependencies. You can test this by running the command:

rospack find joy

If you get an error, you can install joystick-drivers by running the following command:

sudo apt-get install ros-fuerte-joystick-drivers

followed by

rosdep install joy

Originally posted by piyushk with karma: 2871 on 2012-06-07

This answer was ACCEPTED on the original site

Post score: 6


Original comments

Comment by allenh1 on 2012-06-07:
I'm having issues with this too. For some unknown reason, this doesn't work. I updated the rosdep sources, but the joy headers are still not recognized.

Comment by piyushk on 2012-06-07:
Could you elaborate on your problem. Do you have the joystick-drivers stack installed? where does the failure appear?

Comment by jker on 2012-08-09:
I have a similar issue, except with several packages. I used 'sudo apt-get' to get them, and they display their locations when I do 'locate ' but rosdep just returns "No Valid Packages or stacks listed as arguments" when I attempt to rosmake my package or do rosdep install

Comment by piyushk on 2012-08-10:
@jker: it seems like you have a different problem. I think your package is not in your ROS_PACKAGE_PATH (i.e. ROS cannot locate it). With locally built code, you need to use a tool like rosinstall/rosws, or manually list package locations. See http://www.ros.org/wiki/ROS/EnvironmentVariables

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.