0
$\begingroup$

Rosanswers logo

Hi all!

I'm trying to use UWSim and did eveything on the webpage. The problem now is that when I do:

rosmake UWSim --rosdep-install

I get the following error:

  [rosbuild] Including /opt/ros/electric/stacks/ros_comm/clients/rospy/cmake/rospy.cmake
  [rosbuild] Including /opt/ros/electric/stacks/ros_comm/clients/roslisp/cmake/roslisp.cmake
  [rosbuild] Including /opt/ros/electric/stacks/ros_comm/clients/cpp/roscpp/cmake/roscpp.cmake
  -- Configuring done
  -- Generating done
  CMake Warning:
    Manually-specified variables were not used by the project:
  
      CMAKE_TOOLCHAIN_FILE
  
  
  -- Build files have been written to: /home/albert/ros_electric/underwater_simulation/UWSim/build
  cd build && make -l2
  make[1]: Entering directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  make[2]: Entering directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  make[3]: Entering directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  make[3]: Leaving directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  [  0%] Built target rospack_genmsg_libexe
  make[3]: Entering directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  make[3]: Leaving directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  [  0%] Built target rosbuild_precompile
  make[3]: Entering directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  make[3]: Leaving directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  make[3]: Entering directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  Linking CXX executable ../bin/UWSim
  /usr/bin/ld: warning: libosg.so.65, needed by /home/albert/ros_electric/underwater_simulation/osgOcean/lib/libosgOcean.so, not found (try using -rpath or -rpath-link)
  /usr/bin/ld: warning: libosgUtil.so.65, needed by /home/albert/ros_electric/underwater_simulation/osgOcean/lib/libosgOcean.so, not found (try using -rpath or -rpath-link)
  /usr/bin/ld: warning: libosgDB.so.65, needed by /home/albert/ros_electric/underwater_simulation/osgOcean/lib/libosgOcean.so, not found (try using -rpath or -rpath-link)
  /usr/bin/ld: warning: libosgGA.so.65, needed by /home/albert/ros_electric/underwater_simulation/osgOcean/lib/libosgOcean.so, not found (try using -rpath or -rpath-link)
  /usr/bin/ld: warning: libOpenThreads.so.13, needed by /home/albert/ros_electric/underwater_simulation/osgOcean/lib/libosgOcean.so, not found (try using -rpath or -rpath-link)
  /home/albert/ros_electric/underwater_simulation/osgOcean/lib/libosgOcean.so: undefined reference to `OpenThreads::Mutex::Mutex()'
  /home/albert/ros_electric/underwater_simulation/osgOcean/lib/libosgOcean.so: undefined reference to `osgDB::readImageFile(std::basic_string, std::allocator > const&, osgDB::ReaderWriter::Options const*)'
  collect2: ld returned 1 exit status
  make[3]: *** [../bin/UWSim] Error 1
  make[3]: Leaving directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  make[2]: *** [CMakeFiles/UWSim.dir/all] Error 2
  make[2]: Leaving directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'
  make[1]: *** [all] Error 2
  make[1]: Leaving directory `/home/albert/ros_electric/underwater_simulation/UWSim/build'

From which I asume osg lib is missing. I've checked on google how to install it but no result found.

Can somebody give me a hint on how to solve it??

Cheers!


Originally posted by apalomer on ROS Answers with karma: 318 on 2012-06-06

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Did you recently upgrade your distro? You have installed openscenegraph 3.0, which should link against libosg.so.80. However, your osgOcean seems to be compiled against libosg.so.65. Have you tried to pre-clean your build?

rosmake --pre-clean UWSim


Originally posted by Mario Prats with karma: 291 on 2012-06-07

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by apalomer on 2012-06-07:
it worked! thanks mario

Comment by Mario Prats on 2012-06-07:
great! you're welcome

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.