0
$\begingroup$

Rosanswers logo

Filtering a trajectory in the arm warehouse viewer (Fuerte, Ubuntu 11.10) fails for an unknown reason

Using ROS-Industrial ( https://swri-ros-pkg.googlecode.com/svn/trunk )

roslaunch sia10d_mesh_arm_navigation planning_scene_warehouse_viewer_sia10d_mesh.launch

Steps to reproduce:

  1. Select a "new motion plan request" from planning scene warehouse viewer window
  2. Select "Interact" in Rviz and move the robot to a new position
  3. Select "plan a new trajectory" from the planning scene warehouse viewer window
  4. Select "filter trajectory" from the planning scene warehouse viewer window.

The Trajectory filter fails for an unknown reason. An error message is not generated (at least not in rxconsole). An info message from the planning_scene_warehouse node is generated. Sometimes the filter node crashes completely.

The filter fails on all of the arm_navigation packages in ROS-Industrial.

Is this a bug, or am I doing something wrong?


Originally posted by sedwards on ROS Answers with karma: 1601 on 2012-05-30

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I just released a fix - an intern added the option to use different trajectory filters, and renamed the parameter trajectory_filter_service_name to trajectory_filter_1_service_name, and I changed it back. You can either wait for debs to get built and show up or manually edit your launch file in the meantime.


Originally posted by egiljones with karma: 2031 on 2012-05-31

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.