0
$\begingroup$

Rosanswers logo

Hi guys, I'm having trouble with viewing images on rviz using the openni_launch stack. I recently updated my machine to Ubuntu 12.04 and to ROS fuerte. After the update I cannot seem to view any images. The openni.launch file has a few major errors along with a lot of exceptions, and I don't understand what it is saying. Here is the output:

[ERROR] [1337870775.117975609]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]
[ERROR] [1337870775.124459412]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[camera/points_xyzrgb_depth_rgb-15]: started with pid [6752]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[camera/disparity_depth-16]: started with pid [6802]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[camera/disparity_depth_registered-17]: started with pid [6852]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[camera_base_link-18]: started with pid [6872]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[camera_base_link1-19]: started with pid [6895]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[camera_base_link2-20]: started with pid [6920]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[camera_base_link3-21]: started with pid [6942]

And then finally, when I try to view an image in rviz following the guide here: link text Rviz says no messages received for the topic in the GUI and in the terminal sometimes it says dropped 100.00% of messages so far sometimes it doesn't.

On maverick and electric I successfully had rgb-d slam up and running.

Finally, I am new to ROS and have finished the main tutorial but am still wondering if there is any other useful guide out there to learn a bit more, especially about what is the best stack for controlling the iRobot create or what is the best place to get started writing ones own packages that interact with other open source packages. It seems very overwhelming when most packages have 1000s of lines of code. I am running on a bilibot by the way which is basically just a poorly documented modified turtlebot with no community.

I am also following this thread link text But our problems seem to be slightly different.


Originally posted by Rydel on ROS Answers with karma: 600 on 2012-05-24

Post score: 6


Original comments

Comment by thebyohazard on 2012-06-07:
If it's not working, there must be some other error message. The ones you posted here are harmless. See this thread and this ticket.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I have provided a link below that talks about this bug that exists in Python 2.7, 3.2 and 3.3. This is an issue with Python that came integrated with Ubuntu 12.04 - Precise Pangolin.

Click here

Even I am kinda stuck up becuase of this issue. However, I am not really to understand the patch provided in the link nor how it works. I do not exactly know to apply the patch and repair my system. But, if you have any idea do let me know.

All the Best.


Originally posted by SivamPillai with karma: 612 on 2012-06-07

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by thebyohazard on 2012-06-07:
Here's a nice guide about patching. However, this bug doesn't interfere with anything in ROS, it's just annoying. (See the ticket I mentioned in the comment of the original question). Good luck finding your problem!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.