0
$\begingroup$

Rosanswers logo

I have a node that is publishing a lot of messages (approximately 135 per second). It should be publishing more. Every time I publish a message, I print out a debug line, and the number of debug lines exceeds the number of messages received. The messages received have sequential header.seq numbers.

This is using a roscpp node on one computer. The publishing takes place in a callback.

Why would some of the messages not get published?


Originally posted by David Lu on ROS Answers with karma: 10932 on 2012-05-22

Post score: 1


Original comments

Comment by dornhege on 2012-05-23:
If there are sequential numbers my guess would be that some queue in the publisher overruns. Do you see any messages when you switch the loggers to DEBUG?

Comment by Lorenz on 2012-05-23:
How big are your buffers (subscriber and publisher)?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Both of you are right. I only had the queue size set to one, which is seemingly obvious.

In my defense, I checked the constructor for the roscpp Publisher and didn't see a queue size parameter. It's in advertise. D'oh.


Originally posted by David Lu with karma: 10932 on 2012-05-23

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.