0
$\begingroup$

Rosanswers logo

I am trying to re-install ROS, and deleted the old install (which was Electric). I followed the instructions for installing Fuerte, and get a series of "Unmet dependencies" errors saying the packages are broken. I then tried installing electric again, and get the same error with the same list of broken packages (only with electric in the name instead of fuerte). Any idea what could be causing this?

EDIT: more information on the error: Linux version is Ubuntu 10.04

$ sudo apt-get install ros-fuerte-desktop-full

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ros-fuerte-desktop-full: Depends: ros-fuerte-geometry-tutorials (= 0.1.3-s1336 651950~lucid) but it is not going to be installed Depends: ros-fuerte-orocos-kinematics-dynamics (= 0.2 .3-s1336639670~lucid) but it is not going to be installed Depends: ros-fuerte-slam-gmapping (= 1.2.7-s133667560 2~lucid) but it is not going to be installed Depends: ros-fuerte-simulator-gazebo (= 1.6.7-s133665 4046~lucid) but it is not going to be installed Depends: ros-fuerte-visualization (= 1.8.11-s13366454 67~lucid) but it is not going to be installed Depends: ros-fuerte-vision-opencv (= 1.8.2-s133664006 6~lucid) but it is not going to be installed Depends: ros-fuerte-perception-pcl (= 1.2.2-s13366407 65~lucid) but it is not going to be installed Depends: ros-fuerte-geometry-experimental (= 0.2.3-s1 336647863~lucid) but it is not going to be installed Depends: ros-fuerte-common-tutorials (= 0.2.3-s133665 2686~lucid) but it is not going to be installed Depends: ros-fuerte-image-pipeline (= 1.8.2-s13366410 90~lucid) but it is not going to be installed Depends: ros-fuerte-geometry-visualization (= 0.1.1-s 1336660261~lucid) but it is not going to be installed Depends: ros-fuerte-stage (= 1.6.6-s1336651803~lucid) but it is not going to be installed Depends: ros-fuerte-image-transport-plugins (= 1.8.0- s1336640188~lucid) but it is not going to be installed Depends: ros-fuerte-robot-model (= 1.8.0-s1336641692~ lucid) but it is not going to be installed Depends: ros-fuerte-geometry (= 1.8.0-s1336639813~luc id) but it is not going to be installed Depends: ros-fuerte-visualization-tutorials (= 0.6.3- s1336660788~lucid) but it is not going to be installed Depends: ros-fuerte-laser-pipeline (= 1.4.4-s13366436 35~lucid) but it is not going to be installed Depends: ros-fuerte-navigation (= 1.8.1-s1336674623~l ucid) but it is not going to be installed E: Broken packages --- [Originally posted](https://answers.ros.org/question/34143/unmet-dependencies/) by [mlanting](https://answers.ros.org/users/2091/mlanting/) on ROS Answers with karma: 53 on 2012-05-16 Post score: 1 --- ### Original comments **Comment by [Eric Perko](https://answers.ros.org/users/14/eric-perko/) on 2012-05-16**:\ Please include the apt-get line you tried to run and full error output. Also include what version of Ubuntu you are on. **Comment by [mlanting](https://answers.ros.org/users/2091/mlanting/) on 2012-05-16**:\ edited to include error output. **Comment by [Eric Perko](https://answers.ros.org/users/14/eric-perko/) on 2012-05-16**:\ Make sure you are fully up to date (sudo apt-get update) and then try installing one of those unmet dependencies (e.g. sudo apt-get install ros-fuerte-geometry). If you keep trying to install the unmet dependencies, you should eventually get an error stating WHY they are broken and not installable. **Comment by [mlanting](https://answers.ros.org/users/2091/mlanting/) on 2012-05-16**:\ I've tried both of those. Trying a package (I only tried the first ones) gives a message just telling me the package is broken. **Comment by [piyushk](https://answers.ros.org/users/1770/piyushk/) on 2012-05-16**:\ Could you post the error that you get when you try and install one of the packages in the list?
$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I had this problem and localized it to the libeigen3-dev version. The ros install was expecting an older version. I just reverted to the older version using the force option in the Synaptic Package Manager and then did the install of ros-fuerte. It worked after I did the downgrade!


Originally posted by markr with karma: 36 on 2012-05-16

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.