0
$\begingroup$

Rosanswers logo

I try to build a new ros package using rosjava. I followed the tutorial and stored my source code in the new package (i.e. /src/main/java/org/ros/reasoner/). Than I took the sample file for build.gradle

apply plugin: 'application'

mainClassName = 'org.ros.RosRun'

dependencies {
  compile 'ros.rosjava_core:rosjava:0.0.0-SNAPSHOT'
}

When running my gradle with "gradle build" I get the following error.

  :compileJava

  FAILURE: Build failed with an exception.

  * What went wrong:
  Could not resolve all dependencies for configuration ':compile'.
  > Could not find group:ros.rosjava_core, module:rosjava, version:0.0.0-SNAPSHOT.
    Required by:
        :rosjava_cylinder_reasoner:unspecified

rosjava was build according to the tutorial with gradlew install and all went right. What is wrong with my approach?

Cheers,

Markus


Originally posted by Markus Eich on ROS Answers with karma: 202 on 2012-05-16

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I found the mistake. According to the gradle manual, a repository had to be set. I added

repositories {
   mavenLocal()
   maven {
     url 'http://robotbrains.hideho.org/nexus/content/groups/ros-public'
   }
 }

and now it can find the dependencies.


Originally posted by Markus Eich with karma: 202 on 2012-05-21

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.