0
$\begingroup$

Rosanswers logo

Hi !

Another question about mapping this time : I'm doing SLAM with pr2. I roslaunch an empty_world headless where I load a pr2 and wg_walls.

Then I launch rviz_move_base from pr2_navigation_global for visualisation, and pr2_2dnav.launch from pr2_2dnav_slam for laser scan and SLAM. Next is explore_slam.launch from explore_stage (but without stage interface coz I'm using rviz). I modified pr2_2dnav.launch to use slam_mapping-2.xml that is the standard slam_mapping.xml file with the following changes :

  <param name="map_update_interval" value="10.0"/> <!-- was 30.0-->
  <param name="temporalUpdate" value="0.5"/> <!-- was -1.0 -->

In explore_slam.launch, I commented stage node launch :

  <!--
  <node pkg="stage" type="stageros" name="stage" args="$(find gazebo_worlds)/worlds/wg.world" respawn="false" output="screen"/>
   -->

When running, I got an error from pr2_2dnav_slam/pr2_2dnav.launch terminal :

  [ERROR] [1336401780.958141624, 48.135000000]: You cannot update a map with resolution: 0.0500, with a new map that has resolution: 0.1000

I looked in many launch and xml files related to theses nodes but I can't find any explicit "map resolution" parameter that I could set to a value I want. More strange is that the "map resolution" parameter changes during the simulation in rviz (I can't edit it there - click for zoomed view) :

Map w/ reso 0.05 http://anusite.free.fr/simumapreso0p05-6.png Map w/ reso 0.1 http://anusite.free.fr/Simu-mapreso0p1.png

Is there any way to set resolution definitely, or is it a normal feature of theses nodes (but it's generating errors, so I don't think so) ?


Update in comments.


Originally posted by Erwan R. on ROS Answers with karma: 697 on 2012-05-09

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The problem looks to have been solved by increased laser range. I don't understand why, any idea ?


Originally posted by Erwan R. with karma: 697 on 2012-05-14

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.