0
$\begingroup$

Rosanswers logo

Hello

I'm new to ROS and I installed Fuerte on Ubuntu 12.04 (Precise Pangolin) 64bit. The normal examples work well, but gazebo crashes with an illegal instruction error. I get the error with an AMD Phenom II CPU and with an Intel Core 2 CPU as well.

Do you have any ideas?

Thanks Matthias

roslaunch gazebo_worlds empty_world.launch
... logging to /home/abc/.ros/log/67d03dc8-985f-11e1unch-gandalf-21949.log
Checking log directory for disk usage. This may take awh
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is  ignored
process[empty_world_server-1]: started with pid [21969]
Exception AttributeError: AttributeError("'_DummyThread' obje '_Thread__block'",) in  ignored
process[gazebo_gui-2]: started with pid [21976]
Gazebo multi-robot simulator, version 1.0.1
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and 
Released under the Apache 2 License.
http://gazebosim.org

Dbg pluginPaths and GAZEBO_PLUGIN_PATH doesn't exist.Set GAZEBO_PLUGIN_PATHgre's installation path. ...or are you loading via SystemPlug
Gazebo multi-robot simulator, version 1.0.1
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Dbg pluginPaths and GAZEBO_PLUGIN_PATH doesn't exist.Set GAZEBO_PLUGIN_PATH to Ogre's installation path. ...or are you loading via SystemPlugins?
Msg Waiting for master.Msg Waiting for master[ INFO] [1336407365.703087291]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Msg Connected to gazebo master @ http://localhost:11345

Msg Connected to gazebo master @ http://localhost:11345
Illegal instruction (core dumped)
[empty_world_server-1] process has died [pid 21969, exit code 132, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gazebo /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/worlds/empty.world __name:=empty_world_server __log:=/home/abc/.ros/log/67d03dc8-985f-11e1-92e6-485b395bdd54/empty_world_server-1.log].
log file: /home/abc/.ros/log/67d03dc8-985f-11e1-92e6-485b395bdd54/empty_world_server-1*.log
/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui: Zeile 2: 21980 Ungültiger Maschinenbefehl   (Speicherabzug geschrieben) `rospack find gazebo`/gazebo/bin/gzclient -g `rospack find gazebo`/lib/libgazebo_ros_paths_plugin.so
[gazebo_gui-2] process has died [pid 21976, exit code 132, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/abc/.ros/log/67d03dc8-985f-11e1-92e6-485b395bdd54/gazebo_gui-2.log].
log file: /home/abc/.ros/log/67d03dc8-985f-11e1-92e6-485b395bdd54/gazebo_gui-2*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done


Originally posted by Matthias on ROS Answers with karma: 91 on 2012-05-07

Post score: 8


Original comments

Comment by kshitij on 2012-06-05:
been struggling with this for 3-4 days now

Comment by hsu on 2012-06-06:
are you running 1.6.10? (check /opt/ros/fuerte/stacks/simulator_gazebo/CMakeLists.txt).

Comment by Kai Bublitz on 2012-09-04:
for me the same problem appeared after the last gazebo update.(package version 1.6.14-s1346200794~precise). Gazebo worked (kind of) in the previous version. I guess there's nothing I can do except waiting for the next update and hoping it works again in the next version.

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo


Update

Thanks again konradb3, [simulator_gazebo 1.6.15](http://ros.org/wiki/simulator_gazebo/ChangeList/1.6) with SSE4 disabled on the way. Please check [fuerte debbuild](http://www.ros.org/debbuild/fuerte.html) for updates.
[A regression in system path loading](https://bitbucket.org/osrf/gazebo/issue/15/systempaths-getogrepaths-systempaths) might be a possibility, but that should be fixed in 1.6.14.

Originally posted by hsu with karma: 5780 on 2012-08-31

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by SL Remy on 2012-09-01:
Running them separately (rosrun gazebo gui) crashes for me as well (Gazebo 1.6.14 from deb) Dmesg has errors relating to libQtGui.so in the gzclient

Comment by Ugo on 2012-09-03:
Since upgrading to 1.6.14 gazebo crashes for me as well (http://pastebin.com/pGihq74c)

Comment by konradb3 on 2012-09-03:
The reason of crash (at least for me) is that gazebo is compiled using SSE4.1 instructions which are not supported on my cpu.

Comment by Erwan R. on 2013-05-14:
I got a similar issue when spawning PR2 in Gazebo (1.6.16) that wasn't present one week ago. I didn't use ROS last week but I did two updates yesterday and monday 6th that may be related. Is this SSE issue fixed ? I'm using fuerte on ubuntu 10.04.

$\endgroup$
0
$\begingroup$

Rosanswers logo

With a system update last week (including ROS) everything worked. But now it isn't working anymore.

There was another update of ROS a few days ago. I couldn't check directly afterwards, but now it isn't working again unfortunately. I have no real idea what's going on. Maybe a jump to an invalid function pointer?

dmesg has some more information: gzserver[12573] trap invalid opcode ip:7f5b81bf8c01 sp:7f5b441f6ca0 error:0 in libgazebo_common.so.1.0.1[7f5b81ba2000+67000]

gdb says:


Program received signal SIGILL, Illegal instruction.
[Switching to Thread 0x7fffb57fa700 (LWP 17169)]
0x00007ffff7bc6c01 in gazebo::common::Time::Set(double) () from /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/lib/libgazebo_common.so.1
(gdb) bt
#0  0x00007ffff7bc6c01 in gazebo::common::Time::Set(double) () from /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/lib/libgazebo_common.so.1
#1  0x00007ffff745c1ce in gazebo::physics::World::Step() () from /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/lib/libgazebo_physics.so.1
#2  0x00007ffff745c508 in gazebo::physics::World::RunLoop() () from /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/lib/libgazebo_physics.so.1
#3  0x00007ffff6111ce9 in thread_proxy () from /usr/lib/libboost_thread.so.1.46.1
#4  0x00007ffff6c8ce9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007ffff59244bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#6  0x0000000000000000 in ?? ()

The integrated gazebo version crashes too when I start it without ROS. I built gazebo from original sources this weekend and it doesn't crash. Unfortunately the ROS build from the sources still doesn't work out of the box for gazebo.


Originally posted by Matthias with karma: 91 on 2012-05-19

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by hsu on 2012-08-10:
Hi Matthias, thanks for the update. How are you launching gazebo? Does it crash every time? On second thought, if you did "rosrun gazebo gazebo" and "rosrun gazebo gui" separately, with some pause in between, does the error still occur?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.