Rosanswers logo

Im running the command roslaunch openni_camera openni_node.launch and this is what I am getting. I am using Ubuntu 10.10 and i have the full diamondback install... Ive been searching for answers here but havent found anything...

Only otherthing I can think of is that I am running Ubuntu off an 8gb flashdrive

ubuntu@ubuntu:~$ roslaunch openni_camera openni_node.launch ... logging to /home/ubuntu/.ros/log/83abd83a-7ddf-11e1-b9e7-001b774634f0/roslaunch-ubuntu-20385.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is

Originally posted by bub102x on ROS Answers with karma: 11 on 2012-04-03

Post score: 1


1 Answer 1


Rosanswers logo

That looks like perfectly normal output - you may not get any further output in the terminal if the driver is running properly.

You can verify that the driver is output point clouds by checking the /camera/rgb/points topic. To do that, in a separate terminal (while leaving the one the driver is running in open), you would run:

rostopic hz /camera/rgb/points

And that should output the rate at which the driver is publishing point clouds from the Kinect (likely 30Hz) (you may want to use rostopic list to see all of the topics the driver is publishing and select one of those - I may be slightly off on remembering what the topic that openni_camera publishes registered RGB data on).

If you get output from rostopic hz, you could view the points in rviz. To do that, follow the directions on the Diamondback version of the openni_camera docs (Section 4). Make sure you are on the Diamondback documentation by selecting diamondback at the top of the documentation.

Originally posted by Eric Perko with karma: 8406 on 2012-04-03

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by bub102x on 2012-04-03:
Thanks, I will give that a try tomorrow when I have the chance to run it

Comment by bub102x on 2012-04-04:
I tried this and i am getting out put but when I try to view the points in rviz, I do as that guide says but as soon as I turn on pointcloud2 display my CPU usages jumps to 100% and stays there and the view shows very little, nothing recognisable

Comment by tfoote on 2012-04-04:
That sounds like your computer might not be able to keep up with the firehose of data from the Kinect.

Comment by bub102x on 2012-04-04:
I have an intel core 2 processor running at 2.16GHz, 2GB of ram, and a Nvidia Geforce Go 7900 GS with 256mb dedicated ram... is that not enough?

Comment by Eric Perko on 2012-04-04:
How much cpu does your computer use if you just do rostopic hz /camera/rgb/points? The driver only publishes if someone is subscribed, so CPU usage with no subscribers is not a good indicator. You could also play with dynamic_reconfigure to try to get CPU usage down by using lower res images.

Comment by bub102x on 2012-04-06:
runing just hz /camera/rgb/points my cp jumps up high around 80%... i tried on another laptop with a quadcore and all 4 jumped to around 60%. Im guessing there is something wrong with the install

or my other guess is that it is because I am running off an 8gb flash drive?

Comment by tfoote on 2012-04-23:
The CPU usage jump is not unexpected, the node does not actually send data unless something is subscribed. And rostopic is subscribing in a seperate process which requires serializing, sending and deserializing the point cloud stream.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.