0
$\begingroup$

Rosanswers logo

Hi People,

I've been recently working on ROS with my new Husky A200 Robot from Clearpath. Platform Details: OS - Ubuntu 11.10 ROS - ros-electric-desktop-full Sensor - Hokuyo Lidar Issue - rviz output for laser scan

I opened rviz in its default state using

rosrun rviz rviz -l

Later I tried to add an interface for LaserScan and in the topics field I chose /lidar/scan However, I dont see any output and instead I get the error message as shown below:

topic: no message received

Transform:sender=/lidar/hokuyo : For frame [laser]: Frame [laser] does not exist

A simple command like rxplot /lidar/scan gives me the data from my Lidar scanner which implies I am able to communicate with the sensor otherwise.

looking forward for a reply that could help me proceed with my Lidar. Thanks.


Originally posted by SivamPillai on ROS Answers with karma: 612 on 2012-03-27

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

In rviz you should change the .Global Options > Fixed Frame to the laser frame id, "/laser" by default.

I hope it works!


Originally posted by martimorta with karma: 843 on 2012-03-27

This answer was ACCEPTED on the original site

Post score: 6

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.