0
$\begingroup$

Rosanswers logo

Hi

Upon running the sicktoolbox_wrapper with a Sick LMS 291-S05, I repeatedly get the following warning:

[ WARN] [1332426748.056931683]: A scan was probably missed. The last scan was 0.0200344 seconds ago.
[ WARN] [1332426755.581470354]: A scan was probably missed. The last scan was 0.0222227 seconds ago.
[ WARN] [1332426761.766591705]: A scan was probably missed. The last scan was 0.0205155 seconds ago.

The time between the warnings range between 1 and 40 seconds. And the "last scan" is reported to be roughly 0.02 seconds ago.

EDIT: The above statement may give the impression that the warnings are not so frequent. The warnings range between 0 and 40 seconds, and more often at a rate > 1HZ. They are quite frequent.

Upon running "rostopic hz /scan" , I get a rate of between 70 and 74 Hz.

Other symptoms that I think might be related are:

  1. When I run the navigation stack, it appears that the laser scans are too slow and hence cannot be registered accurately. Upon sending a simple goal, in a few seconds, my navigation map in Rviz looks like this: http://tinypic.com/r/akzi86/5. I have run navigation stack before while using the same robot and a different laser and am certain that my navigation parameters are okay. I also reduced the maximum angular and linear velocity in navstack params to 0.7 and 0.2 respectively.

  2. When I run rviz, I notice the laser topic turning red from time to time, and the status going from OK to error. The error message under the laser topic indicates that there were no messages received. This message appears and then disappears in less than a second, however the messages are quite frequent (more frequent than the warnings). I also notice a fluctuation in the number of points (between 181 and 180 and sometimes even 179). Some posts indicated that this should have been resolved by changing the parameter 'resolution' to 1.0, which I have included in my launch file (see below), but to no avail.

  3. If I control the robot via a joystick, I am able to build a good map as long as I keep the speed really slow (a linear velocity of about 0.14 and an angular velocity of about 0.1).

Setup

I am using a ActivMedia PeopleBot robot base with a Sick LMS 291-S05 laser. The laser transmits data to a FitPC3 via a RS232-USB adaptor. (EDIT: This is actually a RS422-USB adaptor, sorry for any confusion caused). The ports/devices are mapped correctly, the device permissions are set.

UPDATE: I run rviz from a remote pc through a wireless connection. ROSCORE runs on the fitpc3 that moves with the robot.

Debug

I ran the SickLMS config file (laser_drivers/sicktoolbox/sicktoolbox/bin/lmsconfig) which produced the following output.

    ./lms_config /dev/laser 500000

    The Sick LIDAR C++/Matlab Toolbox    
    Sick LMS 2xx Config Utility          

*** Attempting to initialize the Sick LMS...
Attempting to open device @ /dev/laser
    Device opened!
Attempting to start buffer monitor...
    Buffer monitor started!
Attempting to set requested baud rate...
    Operating @ 500Kbps
Attempting to sync driver...
    Driver synchronized!
*** Init. complete: Sick LMS is online and ready!
Sick Type: Sick LMS 291-S05
Scan Angle: 180 (deg)
Scan Resolution: 1 (deg)
Measuring Mode: 8m/80m; 3 reflector bits
Measuring Units: Centimeters (cm)

    NOTE - Configuring the Sick LMS - REQUIRES - writing to the device's EEPROM.
    The number of times this can be done is finite (a few thousand).
    Thus, you should configure sparingly.

    Enter your choice: (Ctrl-c to exit)
    [1] Set measuring units
    [2] Set measuring mode
    [3] Set availability level
    [4] Set sensitivity level
    [5] Show detailed configuration

Detailed configuration shows

    =============== Sick LMS Config ===============
Blanking Value: 0
Sensitivity: Standard (~30m @ 10% reflectivity)
Availability: Default (Unspecified)
Measuring Mode: 8m/80m; 3 reflector bits
Measuring Units: Centimeters (cm)
Temporary Field: Not used
Subtractive Fields: Not active
Multiple Evaluation: 2
Suppressed Objects Multiple Evaluation: 0
Dazzling Multiple Evaluation: 20738
Restart Mode: No restart block
Restart Time: 2
Fields B,C Restart Time: 0
Contour Function A: Not active
Contour Function B: Not active
Contour Function C: Not active
Pixel Oriented Evaluation: 0
Single Measured Value Eval. Mode: 0
===============================================

Code

My laser launch file is as follows http://pastebin.com/JC34dUxN

Similar questions

  1. Errors using sicktoolbox wrapper - powerbot
  2. This ticket: https://code.ros.org/trac/ros-pkg/ticket/4673

The conclusion of the above 2 questions was to set the resolution parameter to 1.0 and to increase the baud rate. I have done both.

Update April 5, 2012

  1. The bag file with the laser scans for 1:52 seconds. laser-lag.bag
  2. The output from the laser node for these 2 minutes. laser-lag.txt . You can notice here that I get 55 warnings in the first 1:52 minutes. Can this be considered normal behavior?
  3. I tried another laser of the same model and make and got the same warnings as well.
  4. I found out that the cable connected to the laser is RS422-USB and not RS232-USB! I have included this in the original question as well.
  5. Related to the problem of the laser topic frequently turning red in rviz (error: Scans not received): I ran gmapping (no navigation) and rviz, and the laser topic was frequently turning red in rviz. I then changed the fixed frame to /laser. At this point the laser topic stopped turning red anymore. This led me to believe that rviz was receiving the map or the /map frame too infrequently (I am running rviz on a remote pc through a wireless connection; see:Setup).

To check whether the /map topic was infrequent:

  1. I ran rostopic hz /map on the remote machine. I received a rate of 0.16Hz.
  2. I then ran rosrun tf view_frames, which produced the following output http://tinypic.com/r/25p6787/5.

In my opinion, these values are within safe boundaries.

Hope to receive some good solutions.

Cheers

Shanker Keshavdas

DFKI Saarbruecken, Germany


Originally posted by Shanker on ROS Answers with karma: 259 on 2012-03-22

Post score: 1


Original comments

Comment by Eric Perko on 2012-03-22:
Just to verify - is that USB-RS232 adapter RS-422 compatible? If I recall correctly, the SICK has to be at 500Kbaud and RS-422 in order to send data at 75Hz properly.

Comment by Shanker on 2012-03-23:
I will have to check the cable specifications. There is a RS422-RS232 adapter built into the SICK laser's mounting box, which came with the laser.

Comment by Shanker on 2012-03-23:
I noticed on another post that you reccommend setting the resolution parameter to 1.0 to correct there being a variation of the number of points received. However with resolution=1.0, I still do not notice in RVIZ that I get a variation between 179 and 181 points from time to time. I mention this.

Comment by Eric Perko on 2012-03-23:
I should note that rviz is showing the number of points displayed on the screen, not necessarily the number of points in the laser scan message (it could be fewer if some are not displayed at all). Can you record and post a short bagfile? Fluctuating number of points does seem bad.

Comment by Eric Perko on 2012-03-23:
I recommended setting the resolution to 1.0, since that's what corrected the problem for me with the missed scan warnings. However, you should note the resolution of the ticket: the missed scan warnings were removed due to not actually being a good indicator that a scan was missed.

Comment by Shanker on 2012-04-04:
I have set the resolution to 1.0, this does not seem to fix the problem.

Comment by Shanker on 2012-04-05:
Yes, you are right. With the update that came with that ticket (4 weeks back), I do not get the warnings anymore.

Comment by Shanker on 2012-04-05:
Eric, you were right about the cable. I checked the specifications, and it is infact a RS 422-USB cable and not RS232 I have posted further details of my tests in an update today.

Comment by Eric Perko on 2012-04-05:
Glad you got things working. For future questions, it's important to note whatever you are running wirelessly at the beginning. If you've solved your question, please put the steps you followed in an answer so that it can be marked as accepted for the next person with this problem.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

To conclude, the warnings associated with the scans stopped appearing upon update to the latest version of sicklms_wrapper associated with this ticket. It was likely to be not associated with the errors obtained in Rviz as Rviz was running on a remote system via wireless, so it is likely a connection problem. The problems with navigation should be handled separately from this question.


Originally posted by Shanker with karma: 259 on 2012-04-12

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.