Rosanswers logo

Hello. I'm Korean student. So i cannot speak English very well. Thank you for your consideration.

I am setting Turtlebot on my netbook and my notebook (Network Connection) http://www.ros.org/wiki/Robots/TurtleBot/Network%20Setup

My netbook is TurtleBot laptop. My notebook is Workstation.

I am able to ping each other. One is and another is

and i can see "echo $ROS_MASTER_URI" and "echo $ROS_HOSTNAME". "turtlebot start/running, process 16951" also.

but when i enter the command "rostopic list", i see "ERROR: Unable to communicate with master!"

I don't know why.. because when i set "Network Setup" first time, there work correctly.. but after the reboot, i cannot do anything..

Please help me ~.~

Originally posted by SanghaNam on ROS Answers with karma: 54 on 2012-03-20

Post score: 1

Original comments

Comment by weiin on 2012-03-20:
could you post the output of "echo $ROS_MASTER_URI" and "echo $ROS_HOSTNAME"? Many times when I get this error, it's because of settings error

Comment by SanghaNam on 2012-03-21:
my notebook.. ROS_MASTER_URI == and ROS_HOSTNAME == and my netbook.. ROS_MASTER_URI == and ROS_HOSTNAME ==

Comment by SanghaNam on 2012-03-21:
IP of my notebook is (turtlebot-workspace) IP of my netbook is (turtlebot-robot)

Comment by SanghaNam on 2012-03-21:
i think "roscore" is right.. but.. i cannot start turtlebot service.. when i enter the command "sudo service turtlebot start", i can see the message "rustlebot start/running, process 3326" and i enter the command "rostopic list", i can see the message only "/rosout" and "/rosout_agg" i don't know..

Comment by weiin on 2012-03-22:
not sure if it's a typo, but in your comments, your turtlebot-workspace IP does not match the notebook's ROS_HOSTNAME so that could be why it's not working correctly

Comment by SanghaNam on 2012-03-23:
oh sorry. i was miss typing.. t.t


1 Answer 1


Rosanswers logo

I am not familiar with the turtlebot setup, but this typically means that you do not have a roscore running. Open a new shell, type "roscore" and try again...

Originally posted by michikarg with karma: 2108 on 2012-03-20

This answer was ACCEPTED on the original site

Post score: 3


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.