0
$\begingroup$

Rosanswers logo

Hi, I am trying to use the package/ lauch file - husky_kinect/ explore.launch provided by clearpath to interface kinect with Husky, using Multiple machine communication from my Laptop connected through Wi-fi.

However, I get the following message in the terminal:


core service [/rosout] found

process[clearpath/robots/default/husky/clearpath_base-1]: started with pid [3430]

process[clearpath/robots/default/openni_node1-2]: started with pid [3431]

process[clearpath/robots/default/kinect_base_link-3]: started with pid [3434]

process[clearpath/robots/default/kinect_base_link1-4]: started with pid [3435]

process[clearpath/robots/default/kinect_base_link2-5]: started with pid [3436]

process[clearpath/robots/default/kinect_base_link3-6]: started with pid [3437]

process[clearpath/robots/default/skim1-7]: started with pid [3438]

process[clearpath/robots/default/passthrough1-8]: started with pid [3439]

process[clearpath/robots/default/ClearpathDemoExplore1-9]: started with pid [3440]

[ERROR] [WallTime: 1332237175.981882] Connection error on /dev/clearpath. Will retry every second.

[ INFO] [1332237185.228103655]: [/clearpath/robots/default/openni_node1] No devices connected.... waiting for devices to be connected

[ INFO] [1332237186.241847581]: [/clearpath/robots/default/openni_node1] No devices connected.... waiting for devices to be connected

[ INFO] [1332237187.251546161]: [/clearpath/robots/default/openni_node1] No devices connected.... waiting for devices to be connected

[ INFO] [1332237188.267365562]: [/clearpath/robots/default/openni_node1] No devices connected.... waiting for devices to be connected

[ INFO] [1332237189.279634720]: [/clearpath/robots/default/openni_node1] No devices connected.... waiting for devices to be connected


I have been previously able to establish multi-machine communication and have even done teleoperation this way.

Any help would be appreciated. Thanks


Originally posted by SivamPillai on ROS Answers with karma: 612 on 2012-03-20

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi Sivam,

In the past, we've used an autodetect script to look for the Husky serial interface among available ttyUSB and ttyS devices. Unfortunately, this interferes with other serial devices like GPSes and IMUs, so what we're doing now is depending on a udev rule to symlink /dev/clearpath to whatever USB-serial adaptor is being used to connect the Husky to your computer. It sounds like this udev rule isn't set up on your machine.

The standard adaptor we ship is a brown Prolific one. If that's the one you've got, you should be able to set up the rule with:

roscd clearpath_common
sudo ./setup_udev.bash

If you'd like to set it up manually, just grab the clearpath.rules file, stick it in your /etc/udev/rules.d folder, and restart the udev service. There's some good information about udev rules here.


Originally posted by mikepurvis with karma: 1153 on 2012-03-22

This answer was ACCEPTED on the original site

Post score: 3

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.