0
$\begingroup$

Rosanswers logo

hanbo@ubuntu:~/ros_workspace/my_package$ rosmake my_package [ rosmake ] Packages requested are: ['my_package']
[ rosmake ] Logging to directory/home/hanbo/.ros/rosmake/rosmake_output-20120314-055706 [ rosmake ] Expanded args ['my_package'] to: ['my_package']
[ rosmake ] Checking rosdeps compliance for packages my_package. This may take a few seconds. Failed to find stack for package [rosgraph_msgs] Failed to load rosdep.yaml for package [rosgraph_msgs]:Cannot locate installation of package rosgraph_msgs: [rospack] couldn't find package [rosgraph_msgs]. ROS_ROOT[/opt/ros/electric/ros] ROS_PACKAGE_PATH[/home/hanbo/ros_workspace] Failed to find stack for package [sensor_msgs] Failed to load rosdep.yaml for package [sensor_msgs]:Cannot locate installation of package sensor_msgs: [rospack] couldn't find package [sensor_msgs]. ROS_ROOT[/opt/ros/electric/ros] ROS_PACKAGE_PATH[/home/hanbo/ros_workspace] Failed to find stack for package [std_msgs] Failed to load rosdep.yaml for package [std_msgs]:Cannot locate installation of package std_msgs: [rospack] couldn't find package [std_msgs]. ROS_ROOT[/opt/ros/electric/ros] ROS_PACKAGE_PATH[/home/hanbo/ros_workspace] Failed to find stack for package [rostest] Failed to load rosdep.yaml for package [rostest]:Cannot locate installation of package rostest: [rospack] couldn't find package [rostest]. ROS_ROOT[/opt/ros/electric/ros] ROS_PACKAGE_PATH[/home/hanbo/ros_workspace] Failed to find stack for package [test_ros] Failed to load rosdep.yaml for package [test_ros]:Cannot locate installation of package test_ros: [rospack] couldn't find package [test_ros]. ROS_ROOT[/opt/ros/electric/ros] ROS_PACKAGE_PATH[/home/hanbo/ros_workspace] [ rosmake ] rosdep check passed all system dependencies in packages
[rosmake-0] Starting >>> my_package [ make ]
[rosmake-0] Finished <<< my_package [SKIP] No rule to make target None
[ rosmake ] Results:
[ rosmake ] Built 1 packages with 0 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/hanbo/.ros/rosmake/rosmake_output-20120314-055706

  • List item

Originally posted by hanbo on ROS Answers with karma: 3 on 2012-03-13

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It looks like your ROS_PACKAGE_PATH is not set up correctly. Also, rosjava does not support rosmake. See http://docs.rosjava.googlecode.com/hg/rosjava_core/html/building.html


Originally posted by damonkohler with karma: 3838 on 2012-03-14

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.