0
$\begingroup$

Rosanswers logo

I got the following message when I try to run rviz through urdf_tutorials:

(rviz:3447): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(rviz:3447): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(rviz:3447): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(rviz:3447): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
The program 'rviz' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 22 error_code 9 request_code 137 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

The log says

[ INFO] [1330220460.687401287]: rviz revision number 1.6.7
[ INFO] [1330220460.687490754]: ogre_tools revision number 1.6.2
[ INFO] [1330220460.687512474]: compiled against OGRE version 1.7.3 (Cthugha)
[ INFO] [1330220460.790543031]: Loading general config from [/home/conrado/.rviz/config]
[ INFO] [1330220460.791031850]: Loading display config from [/home/conrado/.rviz/display_config]
[ INFO] [1330220460.859120679]: RTT Preferred Mode is PBuffer.

The most strange of all that is that it runs perfectly when I first run it (sometimes it works when I wait a long time before running again or lock the screen after the error but the ruslaunch command still executing). If I close and try to reopen, it gives that error. I checked and there is no program running in background that could cause some problem. I'm using Ubuntu 11.10. I'll keep searching for the source of the problem, as it seems related to the X library itself.


Originally posted by Conrado Miranda on ROS Answers with karma: 53 on 2012-02-25

Post score: 0


Original comments

Comment by Eric Perko on 2012-02-25:
Please post what type of GPU you have and which drivers you are using (e.g. a restricted driver?).

Comment by Conrado Miranda on 2012-02-26:
I'm in a notebook without any GPU. I'm using a default Ubuntu 11.10 installation.

Comment by felix k on 2012-02-27:
@Conrado: Even if you have no dedicated powerful graphics card your GPU is from either Intel, Nvidia or AMD/ATI. Check the "Additional Drivers" in the settings if you have alternatives available and try them.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This BadDrawable error is generally related to issues with either your GPU being too old or buggy drivers. See the answers to rviz problem with ubuntu 10.04 and rviz crashing at startup with baddrawable. Also see the RViz troubleshooting page.

Since you are only having problems after closing it, I would guess something is leaving your graphics driver in a bad state. Try changing up the RTT mode as referenced in the above answers to see if that fixes things.


Originally posted by Eric Perko with karma: 8406 on 2012-02-26

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.