0
$\begingroup$

Rosanswers logo

Hi, I run the android teleop on electric turtlebot. The android_teleop works fine, I can see the video and the teleop works without any problem.

I modified the file: turtlebot_bringup/mock_apps/turtlebot_apps.installed, add make_a_map and map_nav into the app chooser.

Then I try to use the make_a_map app. On my android tablet, there's no video or map image.

The log message is:

[/openni_camera] No devices connected.... Waiting for devices to be connected
Still waiting on map...

I can move the turtlebot around by touching the cross icon. Then I tried to save the map, there's an error message on android device:

 Naming map failed:

No map is saved. I did installed map store by running: sudo apt-get install ros-electric-map-store

There's error message on the turtlebot netbook:

[ERROR] [1329741872.385404822]: Dynamic map getter service call failed.

And i can see openni_camera and slam_gmapping nodes are created:

rosnode list
/android1329726229488
/app_manager
/camera_throttle
/diagnostic_aggregator
/kinect_base_link
/kinect_base_link1
/kinect_base_link2
/kinect_base_link3
/kinect_laser
/kinect_laser_narrow
/map_saver
/master_sync_turtlebot3_7762_1685468291504748191
/master_sync_turtlebot3_7762_3382019221689062785
/mongo
/move_base
/openni_camera
/openni_manager
/pointcloud_throttle
/robot_pose_ekf
/robot_state_publisher
/rosout
/slam_gmapping
/tf_throttle_for_android_gui
/turtlebot_laptop_battery
/turtlebot_node

But by running rxgraph, it seems that there's no node subscribing the openni_camera data. Seems i can't upload the image file of rxgraph.

I've checked the latest code of turtlebot_teleop in mecurial repository. all the files i have are the latest version. And I did modified the file: turtlebot_teleop//app/android_map_nav.launch:

<!--- Run AMCL --> 
<include file="$(find turtlebot_navigation)/config/amcl_turtlebot_map_from_topic.launch" />

to:

<!--- Run AMCL -->
<include file="$(find turtlebot_navigation)/config/amcl_turtlebot.launch" />

since file: amcl_turtlebot_map_from_topic.launch doesn't exist in electric turtlebot.

Anyone has any clue what might be the problem?

Thanks a lot! /ma

Update: I manually deleted the directory:

/opt/ros/electric/stacks/turtlebot_apps/

Then checked out the latest source code in mercurial repository:

hg clone https://kforge.ros.org/turtlebot/turtlebot_apps

Now the android map making app works. I can see the video stream, and the map image. When saving the map, it poped "map saved as xxxx". It seems everything is good.

But when i start the map navigation app, there's video stream, and it shows "waiting for the map manager". On the turtlebot netbook, the log message is:

Still waiting on the map....

I added map making and map navigation app link to the App chooser. But there's no .app file so I don't know how to add "Android map manager" app into the App chooser.

I downloaded "Android map manager" from market, but it can't be started. On the turtlebot netbook, I can't see where is the saved map file.

How to solve this problem? Many thanks to all you for your help!!


Originally posted by Gemini Ma on ROS Answers with karma: 32 on 2012-02-19

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Ok, can you do a source install of turtlebot_apps and see if the patches I just pushed work? This should:

a) enable breaker, which should fix the "no devices connected".

b) take care of the amcl_from_map_topic error (in the correct way, amcl_turtlebot is slightly different).

c) fix some issues with frame names.

I'm not sure on the "naming map failed" part, let's see if these changes can fix it.


Originally posted by fergs with karma: 13902 on 2012-02-20

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Gemini Ma on 2012-02-20:
@fergs - thank you very much. I'll do that. As @Ryan Hickman said, I'm also not sure how to do the source install. I compared my code with the mecurial repository in the silliest way: click files that i thought would be relevant one by one...

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.