Rosanswers logo

I'm having a weird error with remapping arguments on Fuerte. In my rospy node, I have a line like

baud_rate = rospy.param('~baud',4800)

so when I'd like to change that on the commandline, I tried

rosrun nmea_gps_driver nmea_gps_driver.py _baud:=38400

but instead of the parameter being set, I get the following error:

ERROR: Invalid remapping argument '_baud:=38400'

That remapping works just fine in Electric and I don't see anything in the rosrun or Fuerte Migration Guide.

In case it matters, I'm working against the latest Fuerte .debs on Ubuntu 11.10.


Minimal reproducible example:

# test.py
import roslib
import rospy


test_param = rospy.get_param('~test', 4800)

print "Param was: %d" % (test_param)

If I run this like python test.py _test:=38400, I get the error output. See below.

$ python test.py _test:=38400
ERROR: Invalid remapping argument '_test:=38400'
Param was: 4800

Originally posted by Eric Perko on ROS Answers with karma: 8406 on 2012-02-19

Post score: 2


1 Answer 1


Rosanswers logo

This was a bug due to some code refacotrintg. Fixed in r16352. Will be included in next ros_comm update.

BTW: thanks for the simplified test case, made this quick to fix

Originally posted by kwc with karma: 12244 on 2012-02-20

This answer was ACCEPTED on the original site

Post score: 3


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.