Rosanswers logo


This is a question that is related to


It is a follow-up in the sense that in the previous question I proposed to use AMCL and a pre-made map as in the ROS tutorials. In the previous question, I was not using a pre-made map. I was using Gmapping and making the map as I went along. This time I am running AMCL, pretty similar to the tutorial described in:


While following this tutorial, the move_base node dies even before I send a navigation goal. Upon searching ROS-Answers for similar questions, I came across


where the solution was investigated by running gdb and running a back trace. I have attempted the same, and the results of the back trace are attached.

My Procedure

  1. Run Motor drivers
  2. Run Laser drivers
  3. Run relevant transforms
  4. Run pre-made map through map server. [Map](http://www.2shared.com/file/of5o4m7n /ltlobby.html) YAML
  5. Run Navigation : Launch file , costmap_common_params , local_costmap_params , global_costmap_params , base_local_planner .

After a few seconds, the terminal where I run the navigation launch file crashes. Here is the output of that terminal along with the gdb backtrace : output with backtrace

Other Relevant Data

I hope this information is sufficient. Please ask me anything else that you might require.


Originally posted by Shanker on ROS Answers with karma: 259 on 2012-02-06

Post score: 1


1 Answer 1


Rosanswers logo

I would run top while you try to run this program to see how much of your system memory you are consuming. You're using a 4000x4000 pixel map, so this could easily use the majority of your RAM. Maybe I read it wrong, but it looked like you loaded this map more than once in the backtrace. This could explain your problem.

Originally posted by DimitriProsser with karma: 11163 on 2012-02-06

This answer was ACCEPTED on the original site

Post score: 2

Original comments

Comment by Shanker on 2012-02-06:
I can see what you mean. However, I only used the command "rosrun map_server map_server *.yaml" once and before running the navigation launch file. I will try running top and see if it is because I'm using such a large map. Perhaps I could also make the map smaller? I'm not sure how, but i'll try.

Comment by Shanker on 2012-02-21:
Thanks for your answer Dimitri, it was indeed because the default parameters for gmapping, create a map that starts with 200X200 m. Ofcourse it is possible to change the start size of the map using gmapping parameters (xmin, ymax etc.). A small starting map size worked. Thanks!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.