0
$\begingroup$

Rosanswers logo

Hi again folks (I'm back after a short stint on another project)

After some work I managed to get RGBDSLAM running nicely (discovering the long way round that it does NOT work on a VMWare Virtual Machine) and am now struggling to build and use OCTOMAPS.

I have gone through all the RGBDSLAM information and tons of references in ROS Answers without success. There are however some rather different instructions of how to achieve this so, please can you clarify which is the most effective and up to date.

RGBDSLAM is working fine so, here is what Ive done thus far:

FIRST ATTEMPT (as per section 4.1 of http://www.ros.org/wiki/rgbdslam#Octomaps)

  1. GET SOURCE: Checked out latest OCTOMAP experimental code

svn co http://alufr-ros-pkg.googlecode.com/svn/branches/octomap_mapping-experimental/

  1. BUILD: Built experimental OCTOMAP Server

cd ros/octomap_mapping-experimental/build/

cmake ..

make

(Seemed to complete with no errors or warnings - perhaps Ive done this wrong?)

  1. LAUNCH BY ITSELF: Launched OCTOMAP server by itself to test

roslaunch rgbdslam octomap_server.launch

But I get the following error (perhaps its because RGBDSLAM isn't running):

started core service [/rosout] ERROR: cannot launch node of type [octomap_server/octomap_server_node]: Cannot locate node of type [octomap_server_node] in package [octomap_server]

  1. LAUNCH AFTER RGBDSLAM So, as per the instructions I first launched RGBDSLAM using:

roslaunch rgbdslam kinect+rgbdslam.launch

I then captured a scene then tried to launch the OCTOMAP server (obviously using a new Terminal - is this correct?) with:

roslaunch rgbdslam octomap_server.launch

but again I get the following error:

core service [/rosout] found ERROR: cannot launch node of type [octomap_server/octomap_server_node]: Cannot locate node of type [octomap_server_node] in package [octomap_server] No processes to monitor shutting down processing monitor... ... shutting down processing monitor complete

  1. CONFIGURATION: I made the following modifications but they didn't help:

Edit (a copy of) octomap_server/launch/octomap_mapping.launch such that the mapping from cloud_in goes to /rgbdslam/batch_clouds and the value of frame_id is "openni_camera"

Are these changes necessary? Are there more that should be made?

SECOND ATTEMPT (as per section 4 of http://www.ros.org/wiki/rgbdslam/evaluation#Octomapping_Requirements)

  1. SOURCE: Checked out latest OCTOMAP evaluation code

    svn co https://alufr-ros-pkg.googlecode.com/svn/branches/octomap_mapping_color ~/ros/octomap_mapping_color svn co https://code.ros.org/svn/wg-ros-pkg/stacks/motion_planning_common/trunk ~/ros/motion_planning_common

  2. BUILD: Built evaluation OCTOMAP Server

    rosmake motion_planning_common rosmake --rosdep-install octomap_mapping_color

Unfortunately NEITHER of these currently build without errors so I was unable to proceed here too.


So, please could someone clarify, step by step, how I go about setting up and run OCTOMAPS with RGBDSLAM.

Many thanks (and sorry I keep struggling with these seemingly straightforward things :-))


Originally posted by Mike Moore on ROS Answers with karma: 53 on 2012-02-03

Post score: 0


Original comments

Comment by Mike Moore on 2012-02-04:
It looks like the OCTOMAPS build has some missing dependencies on qt4-opengl and qglviewer-qt4 so I tried installing the libqglviewer-qt4-2 and libqglviewer-qt4-dev but they haven't cleared up the build yet. Even rosmake --rosdep-install octomap_mapping-experimental doesn't work...hmmm

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It sounds like octomap hasn't built properly - look in the bin folder of your octomap_server directory and there should be octomap_saver and octomap_server_node.

Do you need the experimental version? Have you just tried: sudo apt-get install ros-electric-octomap-mapping ros-electric-octomap-visualization ?

If you're using the launch files in rgbdslam you shouldn't need to alter the ones in the octomap stack itself. Cloud_in going to /rgbdslam/batch_clouds and frame_id as /map should be fine.

I found I had to add: < param name="base_frame_id" value="/openni_rgb_optical_frame" /> to the octomap server parameters or I got tf errors.


Originally posted by jwrobbo with karma: 258 on 2012-02-04

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by Felix Endres on 2012-02-07:
Have a look at the file "/opt/ros/electric/stacks/octomap_visualization/rosdep.yaml" and install the mentioned packages manually using "apt-get install "

Comment by Mike Moore on 2012-02-04:
Thanks jwroobo, experimental for color OCTOMAPS. Definitely isnt building properly as I still get these missing dep. errors: "Failed to find rosdep qglviewer-qt4 for package octovis on OS:ubuntu version:oneiric" and "Failed to find rosdep qt4-opengl for package octovis on OS:ubuntu version:oneiric"?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.