0
$\begingroup$

Rosanswers logo

So, I am trying to make ROS run on the NAO. I have followed the wiki for Nao-Cross-Compiling, and I get everything to show up on the robot as stated in the wiki. However, when I go to run roscore, just to see if it will work, I get the following error message:

Traceback (most recent call last):
File "/media/external/ros/electric/ros/bin/roscore", line 34, in from ros import roslaunch File "/media/external/ros/electric/ros/core/roslib/src/ros/init.py", line 57, in getattr return import(name) File "/media/external/ros/electric/ros_comm/tools/roslaunch/src/roslaunch/init.py", line 43, in import roslaunch.param_dump File "/media/external/ros/electric/ros_comm/tools/roslaunch/src/roslaunch/param_dump.py", line 43, in import yaml ImportError: No module named yaml

The PYTHONPATH for my setup.sh file looks like this:

PYTHONPATH=/media/external/python:/media/external/ros/electric/ros/core/roslib/src:$PYTHONPATH

The /media/external/python folder contains the yaml folder.

Any suggestions are greatly appreciated.

[edit] OS is Ubuntu 10.04 and nao sdk and toolchain are 1.10.44


Originally posted by dougnets22 on ROS Answers with karma: 61 on 2012-02-02

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You're likely missing the python-yaml package on your system. It's a core system dependency when installing from source instructions


Originally posted by tfoote with karma: 58457 on 2012-02-02

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by dougnets22 on 2012-02-05:
Whenever I run the setup: sudo apt-get install build-essential python-yaml cmake subversion wget python-setuptools mercurial git-core, it tells me that pyton-yamal is already the newest version

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.