0
$\begingroup$

Rosanswers logo

I followed the information for installing rosemacs but this has presented me with some problems. For starters, I didn't have a .emacs file so I created one from scratch (not sure if that's what is supposed to be done). I tried editing this file in both ways described but I keep getting errors.

Warning (initialization): An error occurred while loading `/home/usr/.emacs':
File error: Cannot open load file, rosemacs
To ensure normal operation, you should investigate and remove the
cause of the error in your initialization file.  Start Emacs with
the `--debug-init' option to view a complete error backtrace.

I did exactly that, opening emacs in debug mode through the command line:

$emacs --debug-init

This yields the following in the scratch area once emacs is open:

͂͂͂
Debugger entered--Lisp error: (file-error "Opening directory" "permission denied" "/home/usr/.emacs.d/auto-save-list/")
 directory-files("~/.emacs.d/auto-save-list/" nil "\\`\\.saves-" t)
 (and auto-save-list-file-prefix (file-directory-p (file-name-directory auto-save-list-file-prefix)) (directory-files (file-name-directory auto-save-list-file-prefix) nil (concat "\\`" ...) t))
  delete-process(#)
  (progn (message "Cancelling existing rostopic tracker") (delete-process old-proc))
  (if old-proc (progn (message "Cancelling existing rostopic tracker") (delete-process old-proc)))
  (when old-proc (message "Cancelling existing rostopic tracker") (delete-process old-proc))
  (let ((old-proc ...)) (when old-proc (message "Cancelling existing rostopic tracker") (delete-process old-proc)))
  (let ((name "*rostopic-tracker*")) (let (...) (when old-proc ... ...)) (when (> interval 0) (let ... ... ...)))
  rosemacs/track-topics(8)
  invoke-rosemacs()
  (progn (add-to-list (quote load-path) checked-result) (require (quote rosemacs)) (invoke-rosemacs))
  (progn (progn (add-to-list ... checked-result) (require ...) (invoke-rosemacs)))
  (if checked-result (progn (progn ... ... ...)))
  (when checked-result (progn (add-to-list ... checked-result) (require ...) (invoke-rosemacs)))
  (let* ((result ...) (checked-result ...)) (when checked-result (progn ... ... ...)))
  eval-buffer(# nil "/home/usr/.emacs" nil t)  ; Reading at buffer position 517
  load-with-code-conversion("/home/usr/.emacs" "/home/usr/.emacs" t t)
  load("~/.emacs" t t)

If anyone has an idea as to what might be going on please let me know.


Originally posted by wkr101 on ROS Answers with karma: 63 on 2012-02-02

Post score: 0


Original comments

Comment by Ugo on 2012-02-02:
Could you post the relevant part of your .emacs as well?

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Ho! Apparently you don't have the permission to browse this directory:

(file-error "Opening directory" "permission denied" "/home/usr/.emacs.d/auto-save-list/")

This can be solved by running:

sudo chmod -R a+rw /home/usr/.emacs.d

Hope this helps.


Originally posted by Ugo with karma: 1620 on 2012-02-02

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by wkr101 on 2012-02-02:
I didn't see an option for this. Is it the "mark answer as favorite" (checkmark) option? If so, I just did that.

Comment by Ugo on 2012-02-02:
Happy to help :) You should probably select this as the correct answer then.

Comment by wkr101 on 2012-02-02:
BINGO!! Thanks Ugo, that solved it! I had a feeling it would be something simple like that.

$\endgroup$
0
$\begingroup$

Rosanswers logo

Your .emacs file is a per-user configuration file; it should be in /home/whatever, not in /usr, which is for system libraries and shared data.


Originally posted by Mac with karma: 4119 on 2012-02-02

This answer was NOT ACCEPTED on the original site

Post score: 2


Original comments

Comment by wkr101 on 2012-02-02:
Sorry, I must have confused you with the naming convention. It's not in /usr it's in the home directory as you stated. It's just that the "whatever" is called "usr" in this case.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.