0
$\begingroup$

Rosanswers logo

I have a turtlebot that was working properly in Diamondback, but when I upgraded it to electric (and upgraded the operating system on the workstation and netbook to Ubuntu 11.10), I am having several errors with the turtlebot.

  1. The turtlebot restarts it's service continuously when I launch minimal.launch or turtlebot.launch, with the following output:

    turtlebot@turtlebot-laptop:/opt/ros/electric/stacks/turtlebot/turtlebot_bringup/upstart$ roslaunch turtlebot.launch 
    

    ... logging to /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/roslaunch-turtlebot-laptop-30106.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

    started roslaunch server http://192.168.11.59:44682/

    SUMMARY

    PARAMETERS

    • /use_sim_time
    • /robot_pose_ekf/sensor_timeout
    • /diagnostic_aggregator/analyzers/sensors/path
    • /robot_pose_ekf/imu_used
    • /turtlebot_node/odom_angular_scale_correction
    • /robot/name
    • /diagnostic_aggregator/analyzers/mode/timeout
    • /diagnostic_aggregator/analyzers/sensors/timeout
    • /diagnostic_aggregator/analyzers/power/type
    • /turtlebot_node/update_rate
    • /diagnostic_aggregator/analyzers/power/timeout
    • /diagnostic_aggregator/analyzers/mode/type
    • /turtlebot_node/gyro_scale_correction
    • /diagnostic_aggregator/analyzers/digital_io/path
    • /diagnostic_aggregator/analyzers/digital_io/timeout
    • /rosdistro
    • /robot_pose_ekf/odom_used
    • /robot_description
    • /diagnostic_aggregator/base_path
    • /robot_pose_ekf/freq
    • /app_manager/interface_master
    • /robot_pose_ekf/vo_used
    • /diagnostic_aggregator/analyzers/sensors/type
    • /diagnostic_aggregator/analyzers/digital_io/startswith
    • /diagnostic_aggregator/analyzers/power/path
    • /robot_pose_ekf/output_frame
    • /diagnostic_aggregator/analyzers/mode/path
    • /diagnostic_aggregator/analyzers/digital_io/type
    • /diagnostic_aggregator/analyzers/mode/startswith
    • /rosversion
    • /diagnostic_aggregator/pub_rate
    • /robot_state_publisher/publish_frequency
    • /diagnostic_aggregator/analyzers/sensors/startswith
    • /diagnostic_aggregator/analyzers/power/startswith
    • /turtlebot_node/bonus
    • /robot/type
    • /robot_pose_ekf/publish_tf

    NODES / appmaster (app_manager/appmaster) app_manager (app_manager/app_manager) turtlebot_node (turtlebot_node/turtlebot_node.py) turtlebot_laptop_battery (turtlebot_node/laptop_battery.py) robot_state_publisher (robot_state_publisher/state_publisher) diagnostic_aggregator (diagnostic_aggregator/aggregator_node) robot_pose_ekf (robot_pose_ekf/robot_pose_ekf)

    ROS_MASTER_URI=http://192.168.11.59:11311

    core service [/rosout] found process[appmaster-1]: started with pid [30127] process[app_manager-2]: started with pid [30128] process[turtlebot_node-3]: started with pid [30129] process[turtlebot_laptop_battery-4]: started with pid [30130] process[robot_state_publisher-5]: started with pid [30131] process[diagnostic_aggregator-6]: started with pid [30132] process[robot_pose_ekf-7]: started with pid [30133] Unhandled exception in thread started by <bound method XmlRpcNode.run of <roslib.xmlrpc.XmlRpcNode object at 0x261fbd0>> Traceback (most recent call last): File "/opt/ros/electric/ros/core/roslib/src/roslib/xmlrpc.py", line 195, in run self._run() File "/opt/ros/electric/ros/core/roslib/src/roslib/xmlrpc.py", line 218, in _run self.server = ThreadingXMLRPCServer((bind_address, port), log_requests) File "/opt/ros/electric/ros/core/roslib/src/roslib/xmlrpc.py", line 98, in init SimpleXMLRPCServer.init(self, addr, SilenceableXMLRPCRequestHandler, log_requests) File "/usr/lib/python2.7/SimpleXMLRPCServer.py", line 590, in init SocketServer.TCPServer.init(self, addr, requestHandler, bind_and_activate) File "/usr/lib/python2.7/SocketServer.py", line 408, in init self.server_bind() File "/usr/lib/python2.7/SocketServer.py", line 419, in server_bind self.socket.bind(self.server_address) File "/usr/lib/python2.7/socket.py", line 224, in meth return getattr(self._sock,name)(args) socket.error: [Errno 98] Address already in use [ WARN] [1327603137.252565670]: The root link base_footprint has an inertia specified in the URDF, but KDL does not support a root link with an inertia. As a workaround, you can add an extra dummy link to your URDF. turtlebot_apps.installed loading installation data for [turtlebot_apps.installed] [INFO] [WallTime: 1327603138.372287] Starting app manager for turtlebot [INFO] [WallTime: 1327603138.412161] Waiting for foreign master [http://localhost:11312] to come up... [INFO] [WallTime: 1327603138.419327] Foreign master is available [INFO] [WallTime: 1327603138.457863] Registering (/turtlebot/app_list,http://192.168.11.59:50069/) on master http://localhost:11312 [INFO] [WallTime: 1327603138.470535] Registering (/turtlebot/application/app_status,http://192.168.11.59:50069/) on master http://localhost:11312 turtlebot_apps.installed [INFO] [WallTime: 1327603138.485023] Registering service (/turtlebot/list_apps,rosrpc://192.168.11.59:46104) on master http://localhost:11312 [INFO] [WallTime: 1327603138.496940] Registering service (/turtlebot/start_app,rosrpc://192.168.11.59:46104) on master http://localhost:11312 [INFO] [WallTime: 1327603138.511035] Registering service (/turtlebot/stop_app,rosrpc://192.168.11.59:46104) on master http://localhost:11312 [INFO] [WallTime: 1327603141.503025] serial port: /dev/ttyUSB0 [INFO] [WallTime: 1327603141.503945] update_rate: 30.0 [INFO] [WallTime: 1327603141.504655] drive mode: twist [INFO] [WallTime: 1327603141.505353] has gyro: True shutdown request: new node registered with same name [turtlebot_node-3] process has finished cleanly. log file: /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/turtlebot_node-3.log respawning... [turtlebot_node-3] restarting process process[turtlebot_node-3]: started with pid [30488] [INFO] [WallTime: 1327603151.363323] serial port: /dev/ttyUSB0 [INFO] [WallTime: 1327603151.364292] update_rate: 30.0 [INFO] [WallTime: 1327603151.365230] drive mode: twist [INFO] [WallTime: 1327603151.366290] has gyro: True shutdown request: new node registered with same name [turtlebot_node-3] process has finished cleanly. log file: /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/turtlebot_node-3*.log respawning... [turtlebot_node-3] restarting process process[turtlebot_node-3]: started with pid [30684] [INFO] [WallTime: 1327603161.019963] serial port: /dev/ttyUSB0 [INFO] [WallTime: 1327603161.020760] update_rate: 30.0 [INFO] [WallTime: 1327603161.021372] drive mode: twist [INFO] [WallTime: 1327603161.022025] has gyro: True shutdown request: new node registered with same name [turtlebot_node-3] process has finished cleanly. log file: /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/turtlebot_node-3*.log respawning... [turtlebot_node-3] restarting process process[turtlebot_node-3]: started with pid [30881] [INFO] [WallTime: 1327603170.690763] serial port: /dev/ttyUSB0 [INFO] [WallTime: 1327603170.691764] update_rate: 30.0 [INFO] [WallTime: 1327603170.692763] drive mode: twist [INFO] [WallTime: 1327603170.693762] has gyro: True shutdown request: new node registered with same name [turtlebot_node-3] process has finished cleanly. log file: /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/turtlebot_node-3*.log respawning... [turtlebot_node-3] restarting process process[turtlebot_node-3]: started with pid [31074] [INFO] [WallTime: 1327603180.273073] serial port: /dev/ttyUSB0 [INFO] [WallTime: 1327603180.274148] update_rate: 30.0 [INFO] [WallTime: 1327603180.275294] drive mode: twist [INFO] [WallTime: 1327603180.276331] has gyro: True shutdown request: new node registered with same name [turtlebot_node-3] process has finished cleanly. log file: /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/turtlebot_node-3*.log respawning... [turtlebot_node-3] restarting process process[turtlebot_node-3]: started with pid [31269] [INFO] [WallTime: 1327603190.048126] serial port: /dev/ttyUSB0 [INFO] [WallTime: 1327603190.049202] update_rate: 30.0 [INFO] [WallTime: 1327603190.050300] drive mode: twist [INFO] [WallTime: 1327603190.051241] has gyro: True shutdown request: new node registered with same name [turtlebot_node-3] process has finished cleanly. log file: /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/turtlebot_node-3*.log respawning... [turtlebot_node-3] restarting process process[turtlebot_node-3]: started with pid [31465] [INFO] [WallTime: 1327603199.952413] serial port: /dev/ttyUSB0 [INFO] [WallTime: 1327603199.953996] update_rate: 30.0 [INFO] [WallTime: 1327603199.955070] drive mode: twist [INFO] [WallTime: 1327603199.956104] has gyro: True shutdown request: new node registered with same name [turtlebot_node-3] process has finished cleanly. log file: /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/turtlebot_node-3*.log respawning... [turtlebot_node-3] restarting process process[turtlebot_node-3]: started with pid [31659] [INFO] [WallTime: 1327603209.652445] serial port: /dev/ttyUSB0 [INFO] [WallTime: 1327603209.653340] update_rate: 30.0 [INFO] [WallTime: 1327603209.654194] drive mode: twist [INFO] [WallTime: 1327603209.655096] has gyro: True shutdown request: new node registered with same name [turtlebot_node-3] process has finished cleanly. log file: /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/turtlebot_node-3*.log respawning... [turtlebot_node-3] restarting process process[turtlebot_node-3]: started with pid [31851] [INFO] [WallTime: 1327603219.401412] serial port: /dev/ttyUSB0 [INFO] [WallTime: 1327603219.403077] update_rate: 30.0 [INFO] [WallTime: 1327603219.404601] drive mode: twist [INFO] [WallTime: 1327603219.406203] has gyro: True shutdown request: new node registered with same name [turtlebot_node-3] process has finished cleanly. log file: /home/turtlebot/.ros/log/7dcff916-484a-11e1-b127-485d607f80f5/turtlebot_node-3*.log respawning... [turtlebot_node-3] restarting process process[turtlebot_node-3]: started with pid [32046]

  2. When I try to turn on breaker 0, I get the following error:

    Service call failed with error: service [/turtlebot_node/set_digital_outputs] unavailable

  3. On the turtlebot dashboard, the message log contains the following warning:

    Node: /diagnostic_aggregator Time: 1327603137.674960700 Severity: Warn Location: /tmp/buildd/ros-electric-diagnostics-1.6.1/debian/ros-electric-diagnostics/opt/ros/electric/stacks/diagnostics/diagnostic_aggregator/src/analyzer_group.cpp:AnalyzerGroup::init:109 Published Topics: /rosout

    Analyzer specification should now include the package name. You are using a deprecated API. Please switch from GenericAnalyzer to diagnostic_aggregator/GenericAnalyzer in your Analyzer specification.

The practical upshot of this is that I cannot keep breaker 0 on in order to test the turtlebot arm which I am trying to run off of it. I am, however, able to run programs like the teleoperation successfully. Does anyone have insight as to why this might be happening, and what I can do to fix it? Thank you very much!


Originally posted by Aroarus on ROS Answers with karma: 122 on 2012-01-26

Post score: 0

$\endgroup$

3 Answers 3

0
$\begingroup$

Rosanswers logo

The turtlebot launch files run as a daemon in electric which would cause everything to continuously restart because the two launch files are killing each other and respawing. You don't need to launch minimal.launch in electric see this tutorial: http://ros.org/wiki/turtlebot_bringup/Tutorials/TurtleBot%20Bringup


Originally posted by mmwise with karma: 8372 on 2012-01-26

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by Aroarus on 2012-02-08:
This is no longer working, and I have generated a new post about it. It worked once, but has not done so since. Starting the turtlebot service still leaves the dashboard stale forever. The only way I can get the dashboard to light up is to kill the turtlebot service and run minimal.launch.

Comment by Aroarus on 2012-01-26:
That fixed everything! The dashboard was appearing stale when I started the turtlebot service, so I assumed that I also had to run minimal.launch (based on my diamondback experience), but it turns out that it just needed a minute to get going. Thanks!

$\endgroup$
0
$\begingroup$

Rosanswers logo

Hello, sorry, I don't understand the Answer. What do I need to run then if not minimal? The Bringup tutorial suggests minimal.launch too.

sudo service turtlebot start > does not work. It says that the process is running but sudo service turtlebot status > says it is not

Anyone? Thanks


Originally posted by unine_ros with karma: 26 on 2012-03-29

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

Hey unine_ros

Try

sudo service turtlebot stop

Then Bringup

roslaunch turtlebot_bringup minimal.launch

hope this will solve your problems.


Originally posted by sunilsulania9192 with karma: 224 on 2012-06-17

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.