0
$\begingroup$

Rosanswers logo

Hi, when i am setting up a navigation stack for my pioneer robot but when i am running move_base.launch after receiving a static map from map_server its writing below warning: "Waiting on transform from /base_footprint to /map to become available before running costmap , tf error."

currently my tf_tree is something like this:

odom_combined---> base_footprint ----> base_laser


Originally posted by Alireza on ROS Answers with karma: 717 on 2012-01-25

Post score: 1

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Do you have amcl or gmapping running? When using a static map published by the map server, you need to run amcl. It will localize your robot in the map and publish the transform from map to odom_combined.


Originally posted by Lorenz with karma: 22731 on 2012-01-25

This answer was ACCEPTED on the original site

Post score: 3

$\endgroup$
0
$\begingroup$

Rosanswers logo

AMCL will run with move_base.launch !


Originally posted by Alireza with karma: 717 on 2012-01-25

This answer was NOT ACCEPTED on the original site

Post score: 2


Original comments

Comment by Alireza on 2012-01-25:
Ok,Thanks, Sorry about that , i'm new to Ros community !

Comment by Lorenz on 2012-01-25:
If you checked that amcl is running (e.g. with rosnode list) it doesn't get the data it requires, i.e. either the odom topic or laser scans are not coming in. Please don't answer in a new question but either edit your question or post a comment. This is not a forum.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.