0
$\begingroup$

Rosanswers logo

Hi folks :-)

Apologies for the long post but I have been trying for three days now to install, build and test RGBDSLAM without any success and am getting rather frustrated... surely it shouldn't be so hard :-)

I am quite experienced and have followed the instructions laid out in http://www.ros.org/wiki/rgbdslam and http://ros.org/wiki/electric/Installation/Ubuntu etc. to the letter and have tried all sorts of fixes suggested here, and on other sites, including starting from scratch with fresh Ubuntu installs twice, to no avail.

So, PLEASE could someone run through a fresh install and provide up to date detailed instructions as I see I'm definitely not the first to have build problems.

This is what Ive done, three times, following predominantly http://www.ros.org/wiki/rgbdslam, thus far:

  1. Installed absolutely clean Ubuntu 11.10 64bit version (confirmed with /etc/issue and the output of uname -m)

  2. Installed ROS Electric as required as per http://ros.org/wiki/electric/Installation/Ubuntu. Commands entered in "Terminal" as follows:

a. sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu oneiric main" > /etc/apt/sources.list.d/ros-latest.list'

b. wget http://packages.ros.org/ros.key -O - | sudo apt-key add –

c. sudo apt-get update

d. sudo apt-get install ros-electric-desktop-full

e. echo "source /opt/ros/electric/setup.bash" >> ~/.bashrc

f. . ~/.bashrc

  1. Installed QT4 (QT Creator) via Ubuntu Software Center

  2. Setup RGBDSLAM again as per http://www.ros.org/wiki/rgbdslam

a. mkdir -p ~/ros

b. echo 'export ROS_PACKAGE_PATH=~/ros:$ROS_PACKAGE_PATH' >> ~/.bashrc

c. source ~/.bashrc

d. svn co http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg/rgbdslam

e. svn co https://code.ros.org/svn/ros-pkg/stacks/vslam/trunk/g2o ~/ros/g2o

f. rosmake --rosdep-install rgbdslam

This immediately failed with:

[ rosmake ] Packages requested are: ['rgbdslam'] [ rosmake ] Logging to directory/home/mike/.ros/rosmake/rosmake_output-20120121-085503 [ rosmake ] Expanded args ['rgbdslam'] to:[] [ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['rgbdslam'] [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

  1. So I checked:

a) sudo apt-get install libglew1.5-dev libdevil-dev libsuitesparse-dev No problem

b) Tried to fix .bashrc adding various combinations and orders of export and source commands (not detailed in instructions)

... " enable programmable completion features (you don't need to enable " this, if it's already enabled in /etc/bash.bashrc and /etc/profile " sources /etc/bash.bashrc). if [ -f /etc/bash_completion ] && ! shopt -oq posix; then . /etc/bash_completion fi

export ROS_PACKAGE_PATH=~/ros:$ROS_PACKAGE_PATH source /opt/ros/electric/setup.bash ...

c) Tried to fix electric setup.sh with other changes (also not detailed in instructions) http://answers.ros.org/question/222/error-when-compiling-rgbdslam-for-kinect ... "!/bin/sh

export ROS_ROOT=/opt/ros/electric/ros export PATH=${ROS_ROOT}/bin:${PATH} export PYTHONPATH=${ROS_ROOT}/core/roslib/src:${PYTHONPATH} export ROS_PACKAGE_PATH=/opt/ros/electric/stacks:/home/mike:/home/mike/ros/ros-pkg:~/ros_workspace:$ROS_PACKAGE_PATH if [ ! "$ROS_MASTER_URI" ] ; then export ROS_MASTER_URI=http://localhost:11311 ; fi ...

Tried incrementally odd combos of ROS_PACKAGE_PATH - now you can see its a bit muddled:

c) Confirmed $ROS_PACKAGE_PATH (in response to various mods in response to setup.sh etc) bash: /opt/ros/electric/stacks:/home/mike:/home/mike/ros/ros-pkg:/home/mike/ros_workspace:/home/mike/ros:

d) Tried downloading GSL via Ubuntu Software Center (no mention of this in the instructions) as this cropped up as a missing component at one stage of the installation muddle.

e) And lots of other odd fixes and hunts through source and SVN and apt-get rebuilds etc... phew...

So, PLEASE let me know if I have missed a crucial installation, SVN or build step above, and better still try it out yourself to see whats missing or changed - then please let us know what to do:-)

Best wishes, Mike


Originally posted by Mike Moore on ROS Answers with karma: 53 on 2012-01-21

Post score: 1

$\endgroup$

3 Answers 3

0
$\begingroup$

Rosanswers logo

If you followed this steps literally I think the problem is 4d/e. This svn checkouts like this will end up in your home, not ~/ros and thus cannot be found in ROS_PACKAGE_PATH.

So you should cd ~/ros before the svn co calls.


Originally posted by dornhege with karma: 31395 on 2012-01-22

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$
0
$\begingroup$

Rosanswers logo

For something as complex as this, I recommend using rosinstall to manage your source checkouts.

There are some other hints from this question, which explains the difference between system dependencies and ROS package dependencies.


Originally posted by joq with karma: 25443 on 2012-01-22

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

Problem resolved, VMWare was unfortunately the culprit.

I rebuilt the whole system, yet again, from scratch on a bootable Ubuntu 11.10 64bit partition and it worked imediately (tho I did have to install GSL independently again Felix).

Now I think I have a more fundamental issue, perhaps with an easy, but expensive solution. I think my Intel I3 M330 dual 2.13GHz laptop, with 4GB ram, is simply not up to the task.

The CPU is maxed out whilst Im capturing data and the resultant frame rate is very slow, which in turn is leading (I suspect) to greater deltas between analysed frames, less matching and ultimately, my generated maps are often VERY poor.

(I have tried moving the camera very slowly but this only helped a little bit)

Also, the 4GB fills up extremely quickly so I'm prettly much limited to small room maps.

Do you guys have any advice on the effectiveness of high spec cpu's with RGBDSLAM - as Ive been looking for an excuse to get a new speedy machine:-)

Thanks you all for your patience and superb advice.


Originally posted by Mike Moore with karma: 53 on 2012-01-23

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by Felix Endres on 2012-01-25:
You're welcome. I'd suggest you mark dornheges answer as correct answer, since he spottet the original problem the title relates to.

Comment by Mike Moore on 2012-01-24:
Thats superb news, time to buy the i7, 8gb laptop Ive been eyeing out. The I will look at running without the GUI, and I can wait to get stuck into the trying to use color octomaps........ Thanks for you superb help Felix, we can mark this as answered :-)

Comment by Felix Endres on 2012-01-23:
However, you could try to not subscribe to the point cloud topic of the kinect, this will shift processing requirements from the driver to RGBDSLAM. Then use the ...skip_step parameters, see the example launchfiles. Do not store the pointclouds in RAM, run without GUI (see params) if not required.

Comment by Felix Endres on 2012-01-23:
"Viel hilft viel" is a german saying :-). RGBDSLAM makes good use of many cpu cores. A good 3D graphics card will speed up the GUI and SIFTGPU features. CUDA makes the latter even faster than GLSL. For online usage you need as much RAM as you can get. Offline you can work around this.

Comment by joq on 2012-05-11:
A good question, but please ask it separately. This is a Q&A forum, not a discussion forum.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.