0
$\begingroup$

Rosanswers logo

I try to launch rviz, after install every dependance with the command, but after I get this error, I try to reunstall my driver, I just win a complete reinstallation. So after some Try I need your help: aaaaaa@lDell-System-XPS-L502X:~/dossier/BattleJump$ rosrun rviz rviz [rospack] warning: trailing slash found in ROS_PACKAGE_PATH

(rviz:14577): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(rviz:14577): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(rviz:14577): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(rviz:14577): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap » [ INFO] [1323540787.308309931]: rviz revision number 1.6.7 [ INFO] [1323540787.308393036]: ogre_tools revision number 1.6.2 [ INFO] [1323540787.308423325]: compiled against OGRE version 1.7.3 (Cthugha) Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". [ INFO] [1323540787.446944341]: Loading general config from [/home/aaa/.rviz/config] [ INFO] [1323540787.447057362]: Loading display config from [/home/aaa/.rviz/display_config] [ WARN] [1323540787.447737024]: wxWidgets Warning [Application built with libpng-1.2.46 but running with 1.5.4] [ERROR] [1323540787.447796049]: wxWidgets Error [Couldn't load a PNG image - file is corrupted or not enough memory.] [ INFO] [1323540787.463369478]: RTT Preferred Mode is Copy. Xlib: extension "GLX" missing on display ":0.0". Xlib: extension "GLX" missing on display ":0.0". [ERROR] [1323540787.464643636]: Caught exception while loading: OGRE EXCEPTION(3:RenderingAPIException): Unexpected failure to determine a GLXFBConfig in GLXWindow::create at /tmp/buildd/ros-electric-visualization-common-1.6.2/debian/ros-electric-visualization-common/opt/ros/electric/stacks/visualization_common/ogre/build/ogre_src_v1-7-3/RenderSystems/GL/src/GLX/OgreGLXWindow.cpp (line 302)

I have a Dell xps 15 with 2 graphic cards, an chispset and a real card, it could be at the origine of the problem...

My hardware config: aa@Dell-System-XPS-L502X:~/b$ lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) 01:00.0 VGA compatible controller: nVidia Corporation Device 0df5 (rev a1)


Originally posted by lordcuty on ROS Answers with karma: 16 on 2011-12-10

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I've resolve my problem, It's the problem of the optimus technology by NVidia which is currently not support by linux, I resolve my problem by using bumberblee. for more explication, see: http://doc.ubuntu-fr.org/nvidia_optimus


Originally posted by lordcuty with karma: 16 on 2011-12-10

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.