0
$\begingroup$

Rosanswers logo

Hi all, I'm starting with the turtlebot but can't get the Kinect to be recognized. I am runnig diamondback.

I redid sudo apt-get install openni_kinect just to make sure it was there, but didn't solve the problem.

Output of lsusb:

Bus 005 Device 002: ID 13d3:3315 IMC Networks 
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 008: ID 045e:02b0 Microsoft Corp. 
Bus 001 Device 007: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 002: ID 13d3:5702 IMC Networks 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Output of roslaunch openni_camera openni_node.launch:

Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://turtlebot-laptop:42441/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

NODES
  /
    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [22450]
ROS_MASTER_URI=http://192.168.1.11:11311

setting /run_id to a30405ca-f056-11e0-83fc-5c260a051546
process[rosout-1]: started with pid [22463]
started core service [/rosout]
process[openni_node1-2]: started with pid [22473]
process[kinect_base_link-3]: started with pid [22476]
process[kinect_base_link1-4]: started with pid [22477]
process[kinect_base_link2-5]: started with pid [22478]
process[kinect_base_link3-6]: started with pid [22479]
[ INFO] [1317931571.886741090]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931572.887058521]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931573.887393253]: [/openni_node1] No devices connected.... waiting for devices to be connected

Thanks in advance for any help!


Originally posted by chopchop on ROS Answers with karma: 58 on 2011-11-27

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi, lsusb should give 3 devices of Microsoft as below.

Bus 002 Device 009: ID 045e:02ae Microsoft Corp. 
Bus 002 Device 008: ID 045e:02ad Microsoft Corp. 
Bus 002 Device 007: ID 045e:02b0 Microsoft Corp. 

I mean this is not w r t turtlebot, but in general when connecting Kinect using external power supply. When its disconnected from external supply it gives the one device as in your case.

Thanks, Karthik


Originally posted by karthik with karma: 2831 on 2011-11-27

This answer was ACCEPTED on the original site

Post score: 5


Original comments

Comment by chopchop on 2011-11-27:
Thanks I needed to set the mode to Full in the turtlebot dashboard in order to power up the Kinect.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.