0
$\begingroup$

Rosanswers logo

I have installed turtlebot on my robot and also on the desktop. I am using the software on a 4XXX roomba. The baud rate is the same as the turtlebot. But, the port is not the same. I have tried and tried to edit the turtlebot_node.py configuration file and it will not let me save it. It says I don't have permissions. When I try to change the permissions, it tells me that I am not the owner so i cannot change the permission. This happens on both the netbook AND the desktop. I am loss to what to do next. chmod and chown do not seem to work.


Originally posted by MovieMaker on ROS Answers with karma: 11 on 2011-11-20

Post score: 0


Original comments

Comment by Mac on 2011-11-20:
Can you explain in more detail? What chown and chmod commands are you running?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

If you installed from debians (sudo apt-get install ....) then the files are in /opt/ros/.. which is a protected directory. You probably need to use "sudo" in front of your chmod/chown commands (which executes that one command as superuser, after possibly prompting for your password).

Now, be aware that the changes will be overwritten when you next update your installation. Therefore, a better solution is probably to copy the launch file into a local working directory in which you do have permissions and modify the setup there -- or create a new launch file altogether that just sets your port parameter for the turtlebot driver.

Note: you should never run a "rosrun" or "roslaunch" command with sudo as your superuser account is probably not set up for ROS, and many other bad things could happen.


Originally posted by fergs with karma: 13902 on 2011-11-20

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by MovieMaker on 2011-11-23:
Exactly how would I create a new launch file and set up my ports?

Comment by MovieMaker on 2011-11-23:
OK, I copied the whole ROS directory to my HOME directory. So, as you said, I can now change the file. After I was able to save the file. I tried to run the turtlebot software, but, it still showed tty, USB0 instead of tty,S0 like I changed it to in the file. I checked it and it was how I changed it

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.