0
$\begingroup$

Rosanswers logo

I am using P3DX, RosAria, Hokuyo URG-04LX-F01 to collect data as a bag file and put it into gmapping.

The robot moved very slow (0.03m/s). But I wonder why the map created from gmapping wasn't clear. It seems many data disappear along the way. And when I saw the process while gmapping was working. The registered data was very little. For example, after gmapping registered first scan, the bag file went for around 10 secs then gmapping registered a new scan again. Maybe because of this some data is disappeared.

I attached map image Gmapping created as well. here http://www.flickr.com/photos/parnurzeal/6363494549/ http://www.flickr.com/photos/parnurzeal/6363494549/

How can I fix this? what is the cause for this?


Originally posted by ParNurZeal on ROS Answers with karma: 91 on 2011-11-19

Post score: 1


Original comments

Comment by ParNurZeal on 2011-11-22:
I use the command "rosrun gmapping slam_gmapping scan:=scan" to proceed this bag file.

Comment by ParNurZeal on 2011-11-22:
Thank you for your kindly help. This is the link to bag file. http://www.mediafire.com/?b6r9m4n9w84ub1r

Comment by Brian Gerkey on 2011-11-19:
Can you post your bag file?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Try playing a bit with the GMapping Parameters. If you want more frequent updates (which should be reasonable for a laserscanner with such short range like yours) you could try setting ~linearUpdate to 0.5 or even less.

For your second problem regarding the missing parts of the map, have a look at the description of the ~maxRange parameter. You should make sure, that you are setting ~maxUrange to a lower value than ~maxRange to clear areas of the map, where a laser-beam traverses but does not hit an obstacle within the range of the laserscanner.

Hope that helps.


Originally posted by Ben_S with karma: 2510 on 2011-11-19

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by tom on 2011-12-21:
@ParNurZeal: OK, just wanted to point out some sensor weakness I know of. I was also very surprised to see black painted object are not discovered by the sensor at a range of 1,5-2m, so thought this might be it if the object is wide enough.

Comment by ParNurZeal on 2011-12-21:
not only some data but around 100 degree wide of sensor data disappeared and that's a lot.

Comment by tom on 2011-12-21:
How exactly is the sensor broken? Hokuyo URG-04LX is a low power laser scanner. I observe gaps in sensor measurement often when black objects come along the way or in strong light conditions.

Comment by ParNurZeal on 2011-12-02:
I already found the problem of this. The hokuyo sensor is broken :( some sensor data is disappear. However, your answer is very helpful., Even though some data is disappear, if I can set set the linearUpdate and the map will become clearer.

Comment by roehling on 2011-11-21:
If the update frequency is too high, performance will degrade, because it is difficult to infer the exact motion if the pose change between two scans is close to or even below the sensor noise (according to specs, up to +-4cm at 4m range for this device).

Comment by RB on 2013-11-13:
Hi I am getting an empty map. I paste below yaml file image: map.pgm

resolution: 0.050000

origin: [-100.000000, -100.000000, 0.000000]

negate: 0

occupied_thresh: 0.65

free_thresh: 0.196

Again But no transform from [/GrndTruth] to frame[/map] and no transform from [/base_GrndTruth to frame[/map]. You can view the question http://answers.ros.org/question/94671/error-in-creating-2d-global-map-of-the-environment/

Comment by RND on 2015-01-30:
Hi, quick question that may sound stupid but I'm not too sure about...How can I go about seeing the value of ~maxRange parameter? Also, how can I set the value of ~maxUrange parameter? Thanks!!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.