0
$\begingroup$

Rosanswers logo

I come up with the following error while installing ros-electric-desktop-full:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ros-electric-desktop-full: Depends: ros-electric-vision-opencv (= 1.6.8-s1321009367~lucid) but it is not going to be installed Depends: ros-electric-image-pipeline (= 1.6.3-s1321009993~lucid) but it is not going to be installed Depends: ros-electric-image-transport-plugins (= 1.4.2-s1321009887~lucid) but it is not going to be installed E: Broken packages

So I went ahead and tried to install ros-electric-vision-opencv on its own using "sudo apt-get install ros-electric-vision-opencv", but had the following error message:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ros-electric-vision-opencv: Depends: libopencv2.3-dev (= 2.3.1+svn6514+branch23-8~lucid) but 2.3.1+svn6514+branch23-6~lucid is to be installed E: Broken packages

Is there a problem with the dependencies for libopencv2.3-dev?

Thank you!

Edit1: Looking into the problem further, I noticed that http://packages.ros.org/ros/ubuntu/lists/ros-lucid-electric_lucid_main_i386_Packages (updated today) uses 2.3.1+svn6514+branch23-8~lucid for libopencv2.3-dev. However,http://packages.ros.org/ros/ubuntu/dists/lucid/main/binary-i386/Packages uses 2.3.1+svn6514+branch23-6~lucid. I think this is causing the problem. Should this be reported as a bug?


Originally posted by esha_umn on ROS Answers with karma: 81 on 2011-11-11

Post score: 8


Original comments

Comment by esha_umn on 2011-11-14:
The problem with dependencies has been sorted out. I managed to install electric-desktop-full successfully today.

Comment by Daniel Canelhas on 2011-11-11:
I found this to be the case, as well: The following packages have unmet dependencies:ros-electric-eigen : Depends: libeigen3-dev (= 3.0.1-1+ros4~natty) but 3.0.2-3+natty1 is to be installed

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I had the same problem as the OP (lucid and oneiric). The problem seems to (now) be fixed for me by switching from Freiburg mirror to the main mirror. So it might be fixed upstream but changes need a while to settle down.


Originally posted by demmeln with karma: 4306 on 2011-11-13

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.