0
$\begingroup$

Rosanswers logo

I'm attenting to use the MIT hand_interaction demo. I get the following error from rviz on startup. This problem is not unique to the hand_interaction demo, however. I get it anytime I try to use rviz. Any insight would be appreciated.

Paul.

$: rosrun rviz rviz -d 'rospack find hand_interactin'/config/handdetection.vcg [ INFO] [1320512356.621261088]: rviz revision number 1.6.5 [ INFO] [1320512356.621365862]: ogre_tools revision number 1.6.2 [ INFO] [1320512356.621384260]: compiled against OGRE version 1.7.3 (Cthugha) [ INFO] [1320512357.039602865]: Loading general config from [/home/pyanik/.rviz/config] [ INFO] [1320512357.039742193]: Loading display config from [/home/pyanik/.rviz/display_config] [ INFO] [1320512357.057640160]: RTT Preferred Mode is FBO. The program 'rviz' received an X Window System error. This probably reflects a bug in the program. The error was 'BadDrawable (invalid Pixmap or Window parameter)'. (Details: serial 22 error_code 9 request_code 136 minor_code 3) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.)


Originally posted by Paul0nc on ROS Answers with karma: 271 on 2011-11-05

Post score: 2

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

I think this is a fairly common occurrence (I get it a fair bit too) and Navam's suggestion to try a few times tends to work for me also. But, check out this RViz troubleshooting page and specifically section 3.4 "Segfault during startup". I find that setting the environment variable OGRE_RTT_MODE to Copy in my .bashrc file instead of the default PBuffer gives me many fewer crashes. You can also try the "FBO" mode. To test the Copy mode in the current terminal, run:

export OGRE_RTT_MODE=Copy

then fire up RViz. If this doesn't help, try the FBO mode. If you find one that works, put the corresponding export line in your .bashrc file.

--patrick


Originally posted by Pi Robot with karma: 4046 on 2011-11-05

This answer was ACCEPTED on the original site

Post score: 7


Original comments

Comment by hersh on 2012-02-24:
This is good information generally, but I believe it is relevant to a different startup crash, not the BadDrawable one. Also, the latest nvidia drivers (290.10) seem to have fixed this RTT_MODE bug.

$\endgroup$
0
$\begingroup$

Rosanswers logo

hi,

i get this problem a lot ( yah my graphic drivers are kind of unstable) so what i do is -

  1. rosrun rviz rviz --sync ( add the --sync it even says in the error message)
  2. dont give up even with sync it will fail .... try it 2-3 times
  3. if it still fails do rosmake rviz rviz and repeat step 1 :P

if it works for you , your welcome and if it doesnt well hopefully someone else here has another way :D

Navam


Originally posted by Navam with karma: 45 on 2011-11-05

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by hersh on 2012-02-24:
The --sync argument is interpreted by wxWidgets. In the Fuerte version rviz uses Qt instead, and for Qt the option only has one "-", so it is "rosrun rviz rviz -sync". I don't know that rebuilding rviz will change anything with respect to this error.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.